Every CVE Search/ Get API key

CVE-2013-6385

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third...

5.1 MediumFix available

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third-party modules, performs form validation even when CSRF validation has failed, which might allow remote attackers to trigger application-specific impacts such as arbitrary code execution via application-specific vectors.

Exploit likelihood

3.07%Down 3.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third-party modules, performs form validation even when CSRF validation has failed, which might allow remote attackers to trigger application-specific impacts such as arbitrary code execution via application-specific vectors.

Record
CVE-2013-6385
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third-party modules, performs form validation even when CSRF validation has failed, which might allow remote attackers to trigger application-specific impacts such as arbitrary code execution via application-specific vectors.

Record
CVE-2013-6385
Updated
2026-11-02
EUVDEUVD-2013-6210 No score

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third-party modules, performs form validation even when CSRF validation has failed, which might allow remote attackers to trigger application-specific impacts such as arbitrary code execution via application-specific vectors.

Record
EUVD-2013-6210
Updated
2026-11-03
GitHub AdvisoriesGHSA-fc7r-g457-hvgm No score

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third...

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third-party modules, performs form validation even when CSRF validation has failed, which might allow remote attackers to trigger application-specific impacts such as arbitrary code execution via application-specific vectors.

Record
GHSA-fc7r-g457-hvgm
Weakness
CWE-94
Updated
2026-11-02
OSVMGASA-2013-0359 No score

Updated drupal package fixes security vulnerabilities

Drupal's form API has built-in cross-site request forgery (CSRF) validation, and also allows any module to perform its own validation on the form. In certain common cases, form validation functions may execute unsafe operations (CVE-2013-6385).

Drupal core directly used the mt_rand() pseudorandom number generator for generating security related strings used in several core modules. It was found that brute force tools could determine the seeds making these strings predictable under certain circumstances (CVE-2013-6386).

Image field descriptions are not properly sanitized before they are printed to HTML, thereby exposing a cross-site scripting vulnerability (CVE-2013-6387).

A cross-site scripting vulnerability was found in the Color module. A malicious attacker could trick an authenticated administrative user into visiting a page containing specific JavaScript that could lead to a reflected cross-site scripting attack via JavaScript execution in CSS (CVE-2013-6388).

The Overlay module displays administrative pages as a layer over the current page (using JavaScript), rather than replacing the page in the browser window. The Overlay module did not sufficiently validate URLs prior to displaying their contents, leading to an open redirect vulnerability (CVE-2013-6389).

Record
MGASA-2013-0359
Updated
2026-11-02
OSVUBUNTU-CVE-2013-6385 No score

The form API in Drupal 6.x before 6.29 and 7.x before 7.24, when used with unspecified third-party modules, performs form validation even when CSRF validation has failed, which might allow remote attackers to trigger application-specific impacts such as arbitrary code execution via application-specific vectors.

Record
UBUNTU-CVE-2013-6385
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal7
Debian:7
before 7.14-2+deb7u1, plus listed versions
7.14-27.14-2+deb7u1~bpo60+1
7.14-2+deb7u1
drupal6
Debian:6.0
before 6.29-1, plus listed versions
6.18-16.18-1squeeze16.20-16.20-1~bpo50+16.20-1~bpo60+1
Show 7 moreShow less
6.20-26.22-16.22-1~bpo60+16.26-16.26-1.16.26-1~bpo60+16.28-1
6.29-1
drupal
Mageia:3
before 7.24-1.1.mga3
7.24-1.1.mga3

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-6385 is a medium vulnerability (CVSS 5.1) in Drupal, published November 26, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.07%, the 87th percentile. Fixed in drupal7 7.14-2+deb7u1.

References

Show 5 moreShow less
MoveEnter Open