CVE-2013-6451
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4,...
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
- Record
CVE-2013-6451- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
- Record
CVE-2013-6451- Updated
- 2026-11-02
EUVDEUVD-2013-6258 No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
- Record
EUVD-2013-6258- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-423m-g5gq-97wq No score
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4,...
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
- Record
GHSA-423m-g5gq-97wq- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
- Record
CVE-2013-6451- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-6451
6.1
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
- Record
DEBIAN-CVE-2013-6451- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2013-6451
6.1
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
- Record
UBUNTU-CVE-2013-6451- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2014-0113 No score
Updated mediawiki packages fix security vulnerabilities
MediaWiki user Michael M reported that the fix for CVE-2013-4568 allowed insertion of escaped CSS values which could pass the CSS validation checks, resulting in XSS (CVE-2013-6451).
Chris from RationalWiki reported that SVG files could be uploaded that include external stylesheets, which could lead to XSS when an XSL was used to include JavaScript (CVE-2013-6452).
During internal review, it was discovered that MediaWiki's SVG sanitization could be bypassed when the XML was considered invalid (CVE-2013-6453).
During internal review, it was discovered that MediaWiki displayed some information about deleted pages in the log API, enhanced RecentChanges, and user watchlists (CVE-2013-6472).
Netanel Rubin from Check Point discovered a remote code execution vulnerability in MediaWiki's thumbnail generation for DjVu files. Internal review also discovered similar logic in the PdfHandler extension, which could be exploited in a similar way (CVE-2014-1610).
MediaWiki has been updated to version 1.22.2, which fixes these issues, as well as several others.
Also, the mediawiki-ldapauthentication and mediawiki-math extensions have been updated to newer versions that are compatible with MediaWiki 1.22.
Additionally, the mediawiki-graphviz extension has been obsoleted, due to the fact that it is unmaintained upstream and is vulnerable to cross-site scripting attacks.
Note: if you were using the "instances" feature in these packages to support multiple wiki instances, this feature has now been removed. You will need to maintain separate wiki instances manually.
- Record
MGASA-2014-0113- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mediawikiDebian:12 |
before 1:1.19.10+dfsg-1 | 1:1.19.10+dfsg-1 |
mediawikiDebian:13 |
before 1:1.19.10+dfsg-1 | 1:1.19.10+dfsg-1 |
mediawikiDebian:14 |
before 1:1.19.10+dfsg-1 | 1:1.19.10+dfsg-1 |
mediawikiMageia:3 From an advisory covering 5 CVEs |
before 1.22.2-1.1.mga3 | 1.22.2-1.1.mga3 |
mediawiki-ldapauthenticationMageia:3 From an advisory covering 5 CVEs |
before 2.0f-1.1.mga3 | 2.0f-1.1.mga3 |
mediawiki-mathMageia:3 From an advisory covering 5 CVEs |
before 1.1-1.1.mga3 | 1.1-1.1.mga3 |
mediawikiMageia:4 From an advisory covering 5 CVEs |
before 1.22.2-1.1.mga4 | 1.22.2-1.1.mga4 |
mediawiki-ldapauthenticationMageia:4 From an advisory covering 5 CVEs |
before 2.0f-1.1.mga4 | 2.0f-1.1.mga4 |
mediawiki-mathMageia:4 From an advisory covering 5 CVEs |
before 1.1-1.1.mga4 | 1.1-1.1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-6451 is a medium vulnerability (CVSS 6.1) in Mediawiki, published March 2, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in mediawiki 1:1.19.10+dfsg-1.
References
lists.wikimedia.org/pipermail/mediawiki-announce/2014-January/000138.html
nvd.nist.gov/vuln/detail/CVE-2013-6451
github.com/advisories/GHSA-423m-g5gq-97wq
security-tracker.debian.org/tracker/CVE-2013-6451
advisories.mageia.org/MGASA-2014-0113.html
bugs.mageia.org/show_bug.cgi?id=12337
Show 8 moreShow less
lists.wikimedia.org/pipermail/mediawiki-announce/2014-January/000140.html
lists.fedoraproject.org/pipermail/package-announce/2014-January/127027.html
lists.fedoraproject.org/pipermail/package-announce/2014-February/127948.html
mediawiki.org/wiki/Extension:GraphViz
ubuntu.com/security/CVE-2013-6451
bugzilla.wikimedia.org/show_bug.cgi?id=58088
phabricator.wikimedia.org/T60088
cve.org/CVERecord?id=CVE-2013-6451