Every CVE Search/ Get API key

CVE-2013-6454

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Exploit likelihood

1.46%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Record
CVE-2013-6454
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Record
CVE-2013-6454
Updated
2026-11-02
EUVDEUVD-2013-6261 No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Record
EUVD-2013-6261
Updated
2026-11-03
GitHub AdvisoriesGHSA-vpcq-vv5m-c4vj No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1...

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Record
GHSA-vpcq-vv5m-c4vj
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Record
CVE-2013-6454
Updated
2026-11-02
OSVDEBIAN-CVE-2013-6454 No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Record
DEBIAN-CVE-2013-6454
Updated
2026-11-02
OSVUBUNTU-CVE-2013-6454 No score

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via a -o-link attribute.

Record
UBUNTU-CVE-2013-6454
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.19.10+dfsg-1
1:1.19.10+dfsg-1
mediawiki
Debian:13
before 1:1.19.10+dfsg-1
1:1.19.10+dfsg-1
mediawiki
Debian:14
before 1:1.19.10+dfsg-1
1:1.19.10+dfsg-1
mediawiki
Debian:7
From an advisory covering 11 CVEs
before 1:1.19.14+dfsg-0+deb7u1, plus listed versions
1:1.19.10+dfsg-11:1.19.11+dfsg-0+deb7u11:1.19.11+dfsg-11:1.19.12+dfsg-11:1.19.13+dfsg-1
Show 11 moreShow less
1:1.19.5-11:1.19.5-1+deb7u11:1.19.6-11:1.19.7+dfsg-11:1.19.7+dfsg-1.11:1.19.8+dfsg-11:1.19.8+dfsg-21:1.19.8+dfsg-2.11:1.19.8+dfsg-2.21:1.19.9+dfsg-11:1.19.9+dfsg-2
1:1.19.14+dfsg-0+deb7u1
mediawiki-extensions
Debian:7
From an advisory covering 11 CVEs
before 3.5~deb7u1, plus listed versions
2.113.03.13.23.3
Show 4 moreShow less
3.43~exp13~exp23~exp3
3.5~deb7u1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-6454 is a medium vulnerability (CVSS 4.3) in Mediawiki, published March 30, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.46%, the 73rd percentile. Fixed in mediawiki 1:1.19.10+dfsg-1.

References

MoveEnter Open