CVE-2013-6460
Nokogiri vulnerable to DoS while parsing XML documents
CVE-2013-6460 is a medium vulnerability (CVSS 6.5) in Nokogiri, published November 5, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in nokogiri 1.5.11.
Nokogiri gem 1.5.x has Denial of Service via infinite loop when parsing XML documents
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
Nokogiri gem 1.5.x has Denial of Service via infinite loop when parsing XML documents
- Record
CVE-2013-6460- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-776
- Updated
- 2026-11-02
CVE List No score
Nokogiri gem 1.5.x has Denial of Service via infinite loop when parsing XML documents
- Record
CVE-2013-6460- Updated
- 2026-11-02
EUVDEUVD-2022-2692 No score
Nokogiri gem 1.5.x has Denial of Service via infinite loop when parsing XML documents
- Record
EUVD-2022-2692- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-62qp-3fxm-9wxf
6.5
Nokogiri vulnerable to DoS while parsing XML documents
Nokogiri gem has Denial of Service via infinite loop when parsing XML documents
- Record
GHSA-62qp-3fxm-9wxf- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-776
- Updated
- 2026-11-02
OSVGHSA-62qp-3fxm-9wxf
6.5
Nokogiri vulnerable to DoS while parsing XML documents
Nokogiri gem has Denial of Service via infinite loop when parsing XML documents
- Record
GHSA-62qp-3fxm-9wxf- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-776
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
nokogiriRubyGems |
1.5.0 up to 1.5.11 | 1.5.11 |
nokogiriRubyGems |
1.6.0 up to 1.6.1 | 1.6.1 |
nokogiriRubyGems |
1.5.0 up to 1.5.11, plus listed versions 1.5.11.5.1.rc11.5.101.5.21.5.3 Show 23 moreShow less1.5.3.rc21.5.3.rc31.5.3.rc41.5.3.rc51.5.3.rc61.5.41.5.4.rc11.5.4.rc21.5.4.rc31.5.51.5.5.rc11.5.5.rc21.5.5.rc31.5.61.5.6.rc11.5.6.rc21.5.6.rc31.5.71.5.7.rc11.5.7.rc21.5.7.rc31.5.81.5.9 |
1.5.11 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
security-tracker.debian.org/tracker/CVE-2013-6460
bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-6460
bugzilla.suse.com/show_bug.cgi?id=CVE-2013-6460
access.redhat.com/security/cve/cve-2013-6460
openwall.com/lists/oss-security/2013/12/27/2
securityfocus.com/bid/64513
Show 6 moreShow less
exchange.xforce.ibmcloud.com/vulnerabilities/90058
nvd.nist.gov/vuln/detail/CVE-2013-6460
github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2013-6460.yml
web.archive.org/web/20200229074427/https://www.securityfocus.com/bid/64513
github.com/advisories/GHSA-62qp-3fxm-9wxf
github.com/sparklemotion/nokogiri