Every CVE Search/ Get API key

CVE-2013-7341

Moodle cross-site scripting (XSS) vulnerabilities

4.3 MediumFix available

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.

Exploit likelihood

2.40%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.

Record
CVE-2013-7341
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.

Record
CVE-2013-7341
Updated
2026-11-02
EUVDEUVD-2022-4291 No score

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.

Record
EUVD-2022-4291
Updated
2026-11-03
GitHub AdvisoriesGHSA-j6c3-3c4w-qv8p No score

Moodle cross-site scripting (XSS) vulnerabilities

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.

Record
GHSA-j6c3-3c4w-qv8p
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-j6c3-3c4w-qv8p No score

Moodle cross-site scripting (XSS) vulnerabilities

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.

Record
GHSA-j6c3-3c4w-qv8p
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2014-0160 No score

Updated moodle packages fix multiple security vulnerabilities

Updated moodle package fixes security vulnerabilities:

In Moodle before 2.4.9, question strings were not being filtered correctly possibly allowing cross site scripting, as quiz_question_tostring can cause invalid HTML (CVE-2014-2571).

Feedback Availability dates not honored in complete.php in Moodle before 2.4.9, therefore it was possible to start a Feedback activity while it was supposed to be closed (CVE-2014-0127).

Broken access control vulnerability in Moodle before 2.4.9 with /mod/chat/chat_ajax.php, where capabilities to chat were being checked at the start of a chat, but not during, so changes were not effective immediately (CVE-2014-0122).

In Moodle before 2.4.9, there were missing access checks on Wiki pages allowing students to see pages of other students' individual wikis, through the Recent activity block (CVE-2014-0123).

In Moodle before 2.4.9, cross site scripting was possible with Flowplayer (CVE-2013-7341).

In Moodle before 2.4.9, Forum and Quiz were showing users' email addresses when settings were supposed to be preventing this (CVE-2014-0124).

In Moodle before 2.4.9, alias links to items in an Alfresco repository were provided with information that would allow someone to impersonate the file owner in Alfresco (CVE-2014-0125).

Cross Site Request Forgery in Moodle before 2.4.9 in enrol/imsenterprise/importnow.php, due to inadequate session checking when triggering the import of IMS Enterprise identities (CVE-2014-0126).

Record
MGASA-2014-0160
Updated
2026-11-02
OSVUBUNTU-CVE-2013-7341 No score

Multiple cross-site scripting (XSS) vulnerabilities in Flowplayer Flash before 3.2.17, as used in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2, allow remote attackers to inject arbitrary web script or HTML by (1) providing a crafted playerId or (2) referencing an external domain, a related issue to CVE-2013-7342.

Record
UBUNTU-CVE-2013-7341
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 2.4.9
2.4.9
moodle/moodle
Packagist
2.5.0 up to 2.5.5
2.5.5
moodle/moodle
Packagist
2.6.0 up to 2.6.2
2.6.2
typo3/cms
Packagist
6.2.0 up to 6.2.14
6.2.14
typo3/cms
Packagist
7.0.0 up to 7.3.1
7.3.1
moodle/moodle
Packagist
before 2.4.9, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 13 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8
2.4.9
moodle/moodle
Packagist
2.5.0 up to 2.5.5, plus listed versions
v2.5.0v2.5.1v2.5.2v2.5.3v2.5.4
2.5.5
moodle/moodle
Packagist
2.6.0 up to 2.6.2, plus listed versions
v2.6.0v2.6.1
2.6.2
typo3/cms
Packagist
6.2.0 up to 6.2.14, plus listed versions
6.2.16.2.106.2.10-rc16.2.116.2.12
Show 9 moreShow less
6.2.136.2.26.2.36.2.46.2.56.2.66.2.76.2.86.2.9
6.2.14
typo3/cms
Packagist
7.0.0 up to 7.3.1, plus listed versions
7.0.17.0.27.1.07.2.07.3.0
7.3.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
moodle
Mageia:3
before 2.4.9-1.mga3
2.4.9-1.mga3
moodle
Mageia:4
before 2.4.9-1.mga4
2.4.9-1.mga4
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-7341 is a medium vulnerability (CVSS 4.3) in Flowplayer Flash, published March 22, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.40%, the 84th percentile. Fixed in moodle/moodle 2.4.9.

References

Show 21 moreShow less
MoveEnter Open