Every CVE Search/ Get API key

CVE-2013-7370

methodOverride Middleware Reflected Cross-Site Scripting in connect

6.1 MediumFix available

CVE-2013-7370 is a medium vulnerability (CVSS 6.1) in Sencha Connect, published December 11, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in connect 2.8.1.

node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.42%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

Record
CVE-2013-7370
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

Record
CVE-2013-7370
Updated
2026-11-02
EUVDEUVD-2020-0583 No score

node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

Record
EUVD-2020-0583
Updated
2026-11-03
GitHub AdvisoriesGHSA-3fw8-66wf-pr7m No score

methodOverride Middleware Reflected Cross-Site Scripting in connect

Connect is a stack of middleware that is executed in order in each request.

The "methodOverride" middleware allows the http post to override the method of the request with the value of the "_method" post key or with the header "x-http-method-override".

Because the user post input was not checked, req.method could contain any kind of value. Because the req.method did not match any common method VERB, connect answered with a 404 page containing the "Cannot [method] [url]" content. The method was not properly encoded for output in the browser.

###Example:

~ curl "localhost:3000" -d "_method=<script src=http://nodesecurity.io/xss.js></script>"
Cannot <SCRIPT SRC=HTTP://NODESECURITY.IO/XSS.JS></SCRIPT> /

Recommendation

Update to the newest version of Connect or disable methodOverride. It is not possible to avoid the vulnerability if you have enabled this middleware in the top of your stack.

Record
GHSA-3fw8-66wf-pr7m
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

Record
CVE-2013-7370
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2013-7370 6.1

node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

Record
DEBIAN-CVE-2013-7370
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 7 moreShow less
OSVUBUNTU-CVE-2013-7370 6.1

node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware

Record
UBUNTU-CVE-2013-7370
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVCLSA-2026-1774225190 No score

TuxCare security update for connect (2 CVEs)

TuxCare rebuilt connect to address 2 CVEs. Fixed in 1.9.2-tuxcare.1.

Record
CLSA-2026-1774225190
Updated
2026-11-02
OSVCLSA-2026-1774225191 No score

TuxCare security update for connect (2 CVEs)

TuxCare rebuilt connect to address 2 CVEs. Fixed in 2.6.0-tuxcare.1.

Record
CLSA-2026-1774225191
Updated
2026-11-02
OSVCLSA-2026-1774225192 No score

TuxCare security update for connect (2 CVEs)

TuxCare rebuilt connect to address 2 CVEs. Fixed in 2.7.5-tuxcare.1.

Record
CLSA-2026-1774225192
Updated
2026-11-02
OSVCLSA-2026-1792476098 No score

TuxCare security update for connect (3 CVEs)

TuxCare rebuilt connect to address 3 CVEs. Fixed in 2.7.11-tuxcare.1.

Record
CLSA-2026-1792476098
Updated
2026-11-02
OSVCLSA-2026-1792508732 No score

TuxCare security update for connect (3 CVEs)

TuxCare rebuilt connect to address 3 CVEs. Fixed in 2.7.10-tuxcare.1.

Record
CLSA-2026-1792508732
Updated
2026-11-02
OSVGHSA-3fw8-66wf-pr7m No score

methodOverride Middleware Reflected Cross-Site Scripting in connect

Connect is a stack of middleware that is executed in order in each request.

The "methodOverride" middleware allows the http post to override the method of the request with the value of the "_method" post key or with the header "x-http-method-override".

Because the user post input was not checked, req.method could contain any kind of value. Because the req.method did not match any common method VERB, connect answered with a 404 page containing the "Cannot [method] [url]" content. The method was not properly encoded for output in the browser.

###Example:

~ curl "localhost:3000" -d "_method=<script src=http://nodesecurity.io/xss.js></script>"
Cannot <SCRIPT SRC=HTTP://NODESECURITY.IO/XSS.JS></SCRIPT> /

Recommendation

Update to the newest version of Connect or disable methodOverride. It is not possible to avoid the vulnerability if you have enabled this middleware in the top of your stack.

Record
GHSA-3fw8-66wf-pr7m
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
connect
npm
through 2.8.0
2.8.1
connect
TuxCare:npm
1.9.2-tuxcare.0 up to 1.9.2-tuxcare.1, plus listed versions
1.9.2
1.9.2-tuxcare.1
connect
TuxCare:npm
2.6.0-tuxcare.0 up to 2.6.0-tuxcare.1, plus listed versions
2.6.0
2.6.0-tuxcare.1
connect
TuxCare:npm
2.7.5-tuxcare.0 up to 2.7.5-tuxcare.1, plus listed versions
2.7.5
2.7.5-tuxcare.1
connect
TuxCare:npm
2.7.11-tuxcare.0 up to 2.7.11-tuxcare.1, plus listed versions
2.7.11
2.7.11-tuxcare.1
connect
TuxCare:npm
2.7.10-tuxcare.0 up to 2.7.10-tuxcare.1, plus listed versions
2.7.10
2.7.10-tuxcare.1
node-connect
Debian:12
before 3.0.0-1
3.0.0-1
node-connect
Debian:13
before 3.0.0-1
3.0.0-1
node-connect
Debian:14
before 3.0.0-1
3.0.0-1
connect
npm
before 2.8.1
2.8.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
node-connect
Ubuntu:16.04:LTS
All versions, plus listed versions
3.3.0-1
None known
node-connect
Ubuntu:18.04:LTS
All versions, plus listed versions
3.4.1-1
None known
node-connect
Ubuntu:20.04:LTS
All versions, plus listed versions
3.7.0-2
None known
node-connect
Ubuntu:22.04:LTS
All versions, plus listed versions
3.7.0-23.7.0+~3.4.35-1
None known

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 9 moreShow less
MoveEnter Open