Every CVE Search/ Get API key

CVE-2014-0003

Apache Camel's XSLT component allows remote attackers to execute arbitrary Java methods

7.5 HighFix available

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Exploit likelihood

7.49%Up 3.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Record
CVE-2014-0003
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Record
CVE-2014-0003
Updated
2026-11-02
EUVDEUVD-2018-0612 No score

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Record
EUVD-2018-0612
Updated
2026-11-03
GitHub AdvisoriesGHSA-h6rp-8v4j-hwph No score

Apache Camel's XSLT component allows remote attackers to execute arbitrary Java methods

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Record
GHSA-h6rp-8v4j-hwph
Weakness
CWE-502
Updated
2026-11-02
OSVGHSA-h6rp-8v4j-hwph No score

Apache Camel's XSLT component allows remote attackers to execute arbitrary Java methods

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Record
GHSA-h6rp-8v4j-hwph
Weakness
CWE-502
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.camel:camel-core
Maven
2.11.0 up to 2.11.4
2.11.4
org.apache.camel:camel-core
Maven
2.12.0 up to 2.12.3
2.12.3
org.apache.camel:camel-core
Maven
2.11.0 up to 2.11.4, plus listed versions
2.11.12.11.22.11.3
2.11.4
org.apache.camel:camel-core
Maven
2.12.0 up to 2.12.3, plus listed versions
2.12.12.12.2
2.12.3
activemq
Red Hat:openshift:2.0::el6
From an advisory covering 4 CVEs
before 0:5.9.0-4.redhat.610328.el6op
0:5.9.0-4.redhat.610328.el6op
activemq-client
Red Hat:openshift:2.0::el6
From an advisory covering 4 CVEs
before 0:5.9.0-4.redhat.610328.el6op
0:5.9.0-4.redhat.610328.el6op
activemq
Red Hat:openshift:1.2::el6
From an advisory covering 4 CVEs
before 0:5.9.0-4.redhat.610328.el6op
0:5.9.0-4.redhat.610328.el6op
activemq-client
Red Hat:openshift:1.2::el6
From an advisory covering 4 CVEs
before 0:5.9.0-4.redhat.610328.el6op
0:5.9.0-4.redhat.610328.el6op

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0003 is a high vulnerability (CVSS 7.5) in Apache Camel, published March 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.49%, the 94th percentile. Fixed in org.apache.camel:camel-core 2.11.4.

References

Show 38 moreShow less
MoveEnter Open