Every CVE Search/ Get API key

CVE-2014-0011

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in...

9.8 CriticalFix available

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in TigerVNC before 1.3.1, when NDEBUG is enabled, allow remote VNC servers to cause a denial of service (vncviewer crash) and possibly execute arbitrary code via vectors related to screen image rendering.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.49%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in TigerVNC before 1.3.1, when NDEBUG is enabled, allow remote VNC servers to cause a denial of service (vncviewer crash) and possibly execute arbitrary code via vectors related to screen image rendering.

Record
CVE-2014-0011
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in TigerVNC before 1.3.1, when NDEBUG is enabled, allow remote VNC servers to cause a denial of service (vncviewer crash) and possibly execute arbitrary code via vectors related to screen image rendering.

Record
CVE-2014-0011
Updated
2026-11-02
EUVDEUVD-2014-0115 No score

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in TigerVNC before 1.3.1, when NDEBUG is enabled, allow remote VNC servers to cause a denial of service (vncviewer crash) and possibly execute arbitrary code via vectors related to screen image rendering.

Record
EUVD-2014-0115
Updated
2026-11-03
GitHub AdvisoriesGHSA-v8hp-82fx-5fhc No score

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in...

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in TigerVNC before 1.3.1, when NDEBUG is enabled, allow remote VNC servers to cause a denial of service (vncviewer crash) and possibly execute arbitrary code via vectors related to screen image rendering.

Record
GHSA-v8hp-82fx-5fhc
Updated
2026-11-02
OSV 9.8

Multiple heap-based buffer overflows in the ZRLE_DECODE function in common/rfb/zrleDecode.h in TigerVNC before 1.3.1, when NDEBUG is enabled, allow remote VNC servers to cause a denial of service (vncviewer crash) and possibly execute arbitrary code via vectors related to screen image rendering.

Record
CVE-2014-0011
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2014-0173 No score

Updated tigervnc packages fix CVE-2014-0011

Updated tigervnc packages fix security vulnerability:

A heap-based buffer overflow was found in the way vncviewer rendered certain screen images from a vnc server. If a user could be tricked into connecting to a malicious vnc server, it may cause the vncviewer to crash, or could possibly execute arbitrary code with the permissions of the user running it. This issue was due to an issue in the ZRLE_DECODE() function which performs RLE decoding (CVE-2014-0011).

Record
MGASA-2014-0173
Updated
2026-11-02
OSVopenSUSE-SU-2024:10056-1 No score

libXvnc-devel-1.7.0-2.1 on GA media

These are all security issues fixed in the libXvnc-devel-1.7.0-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10056-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tigervnc
Mageia:3
before 1.1.0-3.2.mga3
1.1.0-3.2.mga3
tigervnc
Mageia:4
before 1.3.0-2.1.mga4
1.3.0-2.1.mga4
tigervnc
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 1.7.0-2.1
1.7.0-2.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0011 is a critical vulnerability (CVSS 9.8) in Tigervnc, published April 15, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.49%, the 84th percentile. Fixed in tigervnc 1.1.0-3.2.mga3.

References

Show 4 moreShow less
MoveEnter Open