Every CVE Search/ Get API key

CVE-2014-0019

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows...

1.9 LowFix available

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Exploit likelihood

0.40%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 1.9

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Record
CVE-2014-0019
CVSS 2.0
1.9 LowAV:L/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Record
CVE-2014-0019
Updated
2026-11-02
EUVDEUVD-2014-0120 No score

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Record
EUVD-2014-0120
Updated
2026-11-03
GitHub AdvisoriesGHSA-3256-v4vm-qpwg No score

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows...

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Record
GHSA-3256-v4vm-qpwg
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Record
CVE-2014-0019
Updated
2026-11-02
OSVDEBIAN-CVE-2014-0019 No score

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Record
DEBIAN-CVE-2014-0019
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0070 No score

Updated socat package fixes security vulnerability

Due to a missing check in socat before 2.0.0-b7 during assembly of the HTTP request line, a long target server name (<hostname> in the documentation) in the PROXY-CONNECT address can cause a stack buffer overrun. Exploitation requires that the attacker is able to provide the target server name to the PROXY-CONNECT address in the command line. This can happen, for example, in scripts that receive data from untrusted sources (CVE-2014-0019).

Record
MGASA-2014-0070
Updated
2026-11-02
OSVopenSUSE-SU-2024:10371-1 No score

socat-1.7.3.1-2.7 on GA media

These are all security issues fixed in the socat-1.7.3.1-2.7 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10371-1
Updated
2026-11-02
OSVSUSE-SU-2016:0343-1 No score

Security update for socat

This update for socat fixes the following issues:

  • CVE-2013-3571: Fix a file descriptor leak that could have been misused for a denial of service attack against socat running in server mode (bsc#821985)
  • CVE-2014-0019: PROXY-CONNECT address was vulnerable to a stack buffer overflow (bsc#860991)
  • Fix a stack overflow in the parser that could have been leveraged to execute arbitrary code (bsc#964844)
Record
SUSE-SU-2016:0343-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-0019 No score

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and 2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of service (segmentation fault) via a long server name in the PROXY-CONNECT address in the command line.

Record
UBUNTU-CVE-2014-0019
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
socat
Debian:12
before 1.7.2.3-1
1.7.2.3-1
socat
Debian:13
before 1.7.2.3-1
1.7.2.3-1
socat
Debian:14
before 1.7.2.3-1
1.7.2.3-1
socat
Mageia:3
before 2.0.0-0.b7.1.mga3
2.0.0-0.b7.1.mga3
socat
Mageia:4
before 2.0.0-0.b7.1.mga4
2.0.0-0.b7.1.mga4
socat
SUSE:Linux Enterprise Desktop 11 SP4
From an advisory covering 2 CVEs
before 1.7.0.0-1.18.2
1.7.0.0-1.18.2
socat
SUSE:Linux Enterprise Server 11 SP4
From an advisory covering 2 CVEs
before 1.7.0.0-1.18.2
1.7.0.0-1.18.2
socat
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
From an advisory covering 2 CVEs
before 1.7.0.0-1.18.2
1.7.0.0-1.18.2
socat
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 1.7.3.1-2.7
1.7.3.1-2.7

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0019 is a low vulnerability (CVSS 1.9) in Dest-unreach Socat, published February 4, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in socat 1.7.2.3-1.

References

Show 18 moreShow less
MoveEnter Open