Every CVE Search/ Get API key

CVE-2014-0048

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via...

9.8 CriticalFix available

CVE-2014-0048 is a critical vulnerability (CVSS 9.8) in Docker, published January 2, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.28%, the 94th percentile. Fixed in docker.io 1.6.0+dfsg1-1.

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

7.28%Up 6.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Record
CVE-2014-0048
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Record
CVE-2014-0048
Updated
2026-11-02
EUVDEUVD-2014-0144 No score

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Record
EUVD-2014-0144
Updated
2026-11-03
GitHub AdvisoriesGHSA-hr9j-w8vh-74wj 9.8

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via...

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Record
GHSA-hr9j-w8vh-74wj
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 9.8

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Record
CVE-2014-0048
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-0048 9.8

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Record
DEBIAN-CVE-2014-0048
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2014-0048 9.8

An issue was found in Docker before 1.6.0. Some programs and scripts in Docker are downloaded via HTTP and then executed or used in unsafe ways.

Record
UBUNTU-CVE-2014-0048
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
docker.io
Debian:12
before 1.6.0+dfsg1-1
1.6.0+dfsg1-1
docker.io
Debian:13
before 1.6.0+dfsg1-1
1.6.0+dfsg1-1
docker.io
Debian:14
before 1.6.0+dfsg1-1
1.6.0+dfsg1-1
docker.io
Ubuntu:14.04:LTS
before 1.6.2~dfsg1-1ubuntu4~14.04.1, plus listed versions
0.6.7+dfsg1-10.6.7+dfsg1-20.6.7+dfsg1-30.7.1+dfsg1-10.7.6+dfsg1-10.8.1+dfsg1-10.9.1~dfsg1-21.0.1~dfsg1-0ubuntu1~ubuntu0.14.04.1
1.6.2~dfsg1-1ubuntu4~14.04.1
docker.io
Ubuntu:16.04:LTS
before 1.10.3-0ubuntu6, plus listed versions
1.6.2~dfsg1-1ubuntu41.10.2-0ubuntu31.10.2-0ubuntu41.10.3-0ubuntu11.10.3-0ubuntu41.10.3-0ubuntu5
1.10.3-0ubuntu6

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 8 moreShow less
MoveEnter Open