Every CVE Search/ Get API key

CVE-2014-0083

net-ldap has weak salt when generating passwords

5.5 MediumFix available

CVE-2014-0083 is a medium vulnerability (CVSS 5.5) in Net-ldap Project Net-ldap, published November 21, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 20th percentile. Fixed in net-ldap 0.16.2.

The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.27%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.

Record
CVE-2014-0083
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-916
Updated
2026-11-02
CVE List No score

The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.

Record
CVE-2014-0083
Updated
2026-11-02
EUVDEUVD-2022-5044 No score

The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.

Record
EUVD-2022-5044
Updated
2026-11-03
GitHub AdvisoriesGHSA-qwgm-mxm4-3q2c 5.5

net-ldap has weak salt when generating passwords

The Ruby net-ldap gem before 0.16.2 uses a weak salt when generating SSHA passwords.

Record
GHSA-qwgm-mxm4-3q2c
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-916
Updated
2026-11-02
OSVGHSA-qwgm-mxm4-3q2c 5.5

net-ldap has weak salt when generating passwords

The Ruby net-ldap gem before 0.16.2 uses a weak salt when generating SSHA passwords.

Record
GHSA-qwgm-mxm4-3q2c
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-916
Updated
2026-11-02
OSVUBUNTU-CVE-2014-0083 5.5

The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.

Record
UBUNTU-CVE-2014-0083
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
net-ldap
RubyGems
before 0.16.2
0.16.2
net-ldap
RubyGems
before 0.16.2, plus listed versions
0.0.50.1.00.1.10.10.00.10.1
Show 19 moreShow less
0.110.12.00.12.10.13.00.14.00.15.00.16.00.16.10.20.2.10.2.20.3.00.3.10.5.10.6.00.6.10.7.00.8.00.9.0
0.16.2
ruby-net-ldap
Ubuntu:16.04:LTS
All versions, plus listed versions
0.8.0-1
None known
ruby-net-ldap
Ubuntu:18.04:LTS
All versions, plus listed versions
0.12.1-20.16.1-1
None known
ruby-net-ldap
Ubuntu:20.04:LTS
All versions, plus listed versions
0.16.1-10.16.1-1ubuntu1
None known
ruby-net-ldap
Ubuntu:22.04:LTS
All versions, plus listed versions
0.16.1-1ubuntu1
None known
ruby-net-ldap
Ubuntu:24.04:LTS
All versions, plus listed versions
0.17.1-2
None known
ruby-net-ldap
Ubuntu:25.10
All versions, plus listed versions
0.19.0-1
None known
ruby-net-ldap
Ubuntu:26.10
All versions, plus listed versions
0.20.0-1
None known
ruby-net-ldap
Ubuntu:26.04:LTS
All versions, plus listed versions
0.19.0-10.20.0-1
None known

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 4 moreShow less
MoveEnter Open