Every CVE Search/ Get API key

CVE-2014-0104

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py...

5.9 MediumFix available

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.83%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.9

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

Record
CVE-2014-0104
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

Record
CVE-2014-0104
Updated
2026-11-02
EUVDEUVD-2014-0184 No score

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

Record
EUVD-2014-0184
Updated
2026-11-03
GitHub AdvisoriesGHSA-c77j-gxmx-7mxq No score

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py...

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

Record
GHSA-c77j-gxmx-7mxq
Updated
2026-11-02
OSV 5.9

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

Record
CVE-2014-0104
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2014-0104 5.9

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

Record
DEBIAN-CVE-2014-0104
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:10237-1 No score

fence-agents-4.0.24+git.1480563949.e67fcd4-1.1 on GA media

These are all security issues fixed in the fence-agents-4.0.24+git.1480563949.e67fcd4-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10237-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fence-agents
Debian:12
before 4.0.17-1
4.0.17-1
fence-agents
Debian:13
before 4.0.17-1
4.0.17-1
fence-agents
Debian:14
before 4.0.17-1
4.0.17-1
fence-agents
openSUSE:Tumbleweed
before 4.0.24+git.1480563949.e67fcd4-1.1
4.0.24+git.1480563949.e67fcd4-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0104 is a medium vulnerability (CVSS 5.9) in Clusterlabs Fence-agents, published January 2, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in fence-agents 4.0.17-1.

References

MoveEnter Open