Every CVE Search/ Get API key

CVE-2014-0133

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x...

7.5 HighFix available

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.

Exploit likelihood

9.55%Up 3.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.

Record
CVE-2014-0133
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.

Record
CVE-2014-0133
Updated
2026-11-02
EUVDEUVD-2014-0194 No score

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.

Record
EUVD-2014-0194
Updated
2026-11-03
GitHub AdvisoriesGHSA-m342-r7h7-vj42 No score

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x...

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.

Record
GHSA-m342-r7h7-vj42
Weakness
CWE-787
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.

Record
CVE-2014-0133
Updated
2026-11-02
OSVDEBIAN-CVE-2014-0133 No score

Heap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.

Record
DEBIAN-CVE-2014-0133
Updated
2026-11-02
OSVMGASA-2014-0136 No score

Updated nginx package fixes security vulnerability

A bug in the experimental SPDY implementation in nginx was found, which might allow an attacker to cause a heap memory buffer overflow in a worker process by using a specially crafted request, potentially resulting in arbitrary code execution (CVE-2014-0133).

Record
MGASA-2014-0136
Updated
2026-11-02
OSVopenSUSE-SU-2024:10044-1 No score

nginx-1.11.4-2.5 on GA media

These are all security issues fixed in the nginx-1.11.4-2.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10044-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nginx
Debian:12
before 1.4.7-1
1.4.7-1
nginx
Debian:13
before 1.4.7-1
1.4.7-1
nginx
Debian:14
before 1.4.7-1
1.4.7-1
nginx
Mageia:4
before 1.4.7-1.mga4
1.4.7-1.mga4
nginx
openSUSE:Tumbleweed
From an advisory covering 11 CVEs
before 1.11.4-2.5
1.11.4-2.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0133 is a high vulnerability (CVSS 7.5) in F5 Nginx, published March 19, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.55%, the 95th percentile. Fixed in nginx 1.4.7-1.

References

Show 14 moreShow less
MoveEnter Open