Every CVE Search/ Get API key

CVE-2014-0166

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3...

6.4 MediumPublic exploitFix available

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Exploit likelihood

9.17%Down 6.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Record
CVE-2014-0166
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:P/A:N
Weakness
CWE-287
Updated
2026-11-02
CVE List No score

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Record
CVE-2014-0166
Updated
2026-11-02
EUVDEUVD-2014-0221 No score

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Record
EUVD-2014-0221
Updated
2026-11-03
GitHub AdvisoriesGHSA-jg4j-hqh7-5qcx No score

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3...

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Record
GHSA-jg4j-hqh7-5qcx
Weakness
CWE-287
Updated
2026-11-02
OSV No score

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Record
CVE-2014-0166
Updated
2026-11-02
OSVDEBIAN-CVE-2014-0166 No score

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Record
DEBIAN-CVE-2014-0166
Updated
2026-11-02
OSVMGASA-2014-0254 No score

Updated wordpress package fixes multiple vulnerabilities

Updated wordpress package fixes security vulnerabilities:

WordPress before 3.7.2 allows remote authenticated users to publish posts by leveraging the Contributor role, related to wp-admin/includes/post.php and wp-admin/includes/class-wp-posts-list-table.php (CVE-2014-0165).

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie (CVE-2014-0166).

The wordpress package has been updated to version 3.9.1, fixing these and other issues.

Record
MGASA-2014-0254
Updated
2026-11-02
OSVUBUNTU-CVE-2014-0166 No score

The wp_validate_auth_cookie function in wp-includes/pluggable.php in WordPress before 3.7.2 and 3.8.x before 3.8.2 does not properly determine the validity of authentication cookies, which makes it easier for remote attackers to obtain access via a forged cookie.

Record
UBUNTU-CVE-2014-0166
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.8.2+dfsg-1
3.8.2+dfsg-1
wordpress
Debian:13
before 3.8.2+dfsg-1
3.8.2+dfsg-1
wordpress
Debian:14
before 3.8.2+dfsg-1
3.8.2+dfsg-1
wordpress
Debian:6.0
before 3.6.1+dfsg-1~deb6u2, plus listed versions
3.0.4+dfsg-13.0.5+dfsg-0+squeeze13.0.5+dfsg-13.2.1+dfsg-13.2.1+dfsg-2
Show 18 moreShow less
3.2.1+dfsg-33.3+dfsg-13.3.1+dfsg-13.3.2+dfsg-13.3.2+dfsg-1~squeeze13.4+dfsg-13.4+dfsg-23.4+dfsg-33.4.1+dfsg-13.4.2+dfsg-13.5+dfsg-13.5.1+dfsg-13.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-13.6.1+dfsg-1~deb6u1
3.6.1+dfsg-1~deb6u2
wordpress
Debian:7
before 3.6.1+dfsg-1~deb7u2, plus listed versions
3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1
Show 10 moreShow less
3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u1
3.6.1+dfsg-1~deb7u2
wordpress
Mageia:3
before 3.9.1-1.mga3
3.9.1-1.mga3
wordpress
Mageia:4
before 3.9.1-1.mga4
3.9.1-1.mga4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubEttack/POC-CVE-2014-01662014-04-26

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0166 is a medium vulnerability (CVSS 6.4) in Wordpress, published April 9, 2014. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 9.17%, the 95th percentile. Fixed in wordpress 3.8.2+dfsg-1.

References

Show 7 moreShow less
MoveEnter Open