Every CVE Search/ Get API key

CVE-2014-0188

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not...

7.5 HighFix available

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not properly handle authentication requests from the remote-user auth plugin, which allows remote attackers to bypass authentication and impersonate arbitrary users via the X-Remote-User header in a request to a passthrough trigger.

Exploit likelihood

1.65%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not properly handle authentication requests from the remote-user auth plugin, which allows remote attackers to bypass authentication and impersonate arbitrary users via the X-Remote-User header in a request to a passthrough trigger.

Record
CVE-2014-0188
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-287
Updated
2026-11-02
CVE List No score

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not properly handle authentication requests from the remote-user auth plugin, which allows remote attackers to bypass authentication and impersonate arbitrary users via the X-Remote-User header in a request to a passthrough trigger.

Record
CVE-2014-0188
Updated
2026-11-02
EUVDEUVD-2014-0240 No score

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not properly handle authentication requests from the remote-user auth plugin, which allows remote attackers to bypass authentication and impersonate arbitrary users via the X-Remote-User header in a request to a passthrough trigger.

Record
EUVD-2014-0240
Updated
2026-11-03
GitHub AdvisoriesGHSA-p2j4-wp52-g89q No score

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not...

The openshift-origin-broker in Red Hat OpenShift Enterprise 2.0.5, 1.2.7, and earlier does not properly handle authentication requests from the remote-user auth plugin, which allows remote attackers to bypass authentication and impersonate arbitrary users via the X-Remote-User header in a request to a passthrough trigger.

Record
GHSA-p2j4-wp52-g89q
Weakness
CWE-287
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openshift-origin-broker
Red Hat:openshift:1.2::el6
before 0:1.5.9-1.el6op
0:1.5.9-1.el6op
rubygem-openshift-origin-auth-remote-user
Red Hat:openshift:1.2::el6
before 0:1.8.4-1.el6op
0:1.8.4-1.el6op
openshift-origin-broker
Red Hat:openshift:2.0::el6
before 0:1.15.3.5-1.el6op
0:1.15.3.5-1.el6op
rubygem-openshift-origin-auth-remote-user
Red Hat:openshift:2.0::el6
before 0:1.17.4-1.el6op
0:1.17.4-1.el6op

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0188 is a high vulnerability (CVSS 7.5) in Redhat Openshift, published April 24, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.65%, the 76th percentile. Fixed in openshift-origin-broker 0:1.5.9-1.el6op.

References

Show 6 moreShow less
MoveEnter Open