Every CVE Search/ Get API key

CVE-2014-0190

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service ...

4.3 MediumFix available

CVE-2014-0190 is a medium vulnerability (CVSS 4.3) in Qt, published May 8, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.96%, the 90th percentile. Fixed in qt4 4.8.6-1.mga3.

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Exploit likelihood

3.96%Up 2.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Record
CVE-2014-0190
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Record
CVE-2014-0190
Updated
2026-11-02
EUVDEUVD-2014-0242 No score

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Record
EUVD-2014-0242
Updated
2026-11-03
GitHub AdvisoriesGHSA-9r7x-qv26-9x2m No score

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service ...

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Record
GHSA-9r7x-qv26-9x2m
Weakness
CWE-476
Updated
2026-11-02
OSVMGASA-2014-0240 No score

Updated qt4 packages fix security vulnerability

A NULL pointer dereference flaw was found in QGIFFormat::fillRect in QtGui. If an application using the qt-x11 libraries opened a malicious GIF file with invalid width and height values, it could cause the application to crash (CVE-2014-0190).

Qt4 has been patched to correct this flaw and has been updated to version 4.8.6, which fixes several other bugs.

Record
MGASA-2014-0240
Updated
2026-11-02
OSVMGASA-2014-0241 No score

Updated qt4 and qtbase5 packages fix security vulnerability

A NULL pointer dereference flaw was found in QGIFFormat::fillRect in QtGui. If an application using the qt-x11 libraries opened a malicious GIF file with invalid width and height values, it could cause the application to crash (CVE-2014-0190).

Qt4 has been patched to correct this flaw and has been updated to version 4.8.6, which fixes several other bugs.

Qtbase5 has also been patched to correct this flaw.

Record
MGASA-2014-0241
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0263 No score

Updated qt3 packages fix security vulnerabilities

Updated qt3 packages fix security vulnerabilities:

QXmlSimpleReader in Qt versions prior to 5.2 supports expansion of internal entities in XML documents without placing restrictions to ensure the document does not cause excessive memory usage. If an application using this API processes untrusted data then the application may use unexpected amounts of memory if a malicious document is processed (CVE-2013-4549).

A NULL pointer dereference flaw was found in QGIFFormat::fillRect in QtGui. If an application using the qt-x11 libraries opened a malicious GIF file with invalid width and height values, it could cause the application to crash (CVE-2014-0190)..

Record
MGASA-2014-0263
Updated
2026-11-02
OSVopenSUSE-SU-2024:10180-1 No score

libqt4-32bit-4.8.7-5.4 on GA media

These are all security issues fixed in the libqt4-32bit-4.8.7-5.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10180-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-0190 No score

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Record
UBUNTU-CVE-2014-0190
Updated
2026-11-02
OSVUSN-2626-1 No score

qt4-x11, qtbase-opensource-src vulnerabilities

Wolfgang Schenk discovered that Qt incorrectly handled certain malformed GIF images. If a user or automated system were tricked into opening a specially crafted GIF image, a remote attacker could use this issue to cause Qt to crash, resulting in a denial of service. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2014-0190)

Fabian Vogt discovered that Qt incorrectly handled certain malformed BMP images. If a user or automated system were tricked into opening a specially crafted BMP image, a remote attacker could use this issue to cause Qt to crash, resulting in a denial of service. (CVE-2015-0295)

Richard Moore and Fabian Vogt discovered that Qt incorrectly handled certain malformed BMP images. If a user or automated system were tricked into opening a specially crafted BMP image, a remote attacker could use this issue to cause Qt to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2015-1858)

Richard Moore and Fabian Vogt discovered that Qt incorrectly handled certain malformed ICO images. If a user or automated system were tricked into opening a specially crafted ICO image, a remote attacker could use this issue to cause Qt to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2015-1859)

Richard Moore and Fabian Vogt discovered that Qt incorrectly handled certain malformed GIF images. If a user or automated system were tricked into opening a specially crafted GIF image, a remote attacker could use this issue to cause Qt to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2015-1860)

Record
USN-2626-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qt4
Mageia:3
before 4.8.6-1.mga3
4.8.6-1.mga3
qt4
Mageia:4
before 4.8.6-1.mga4
4.8.6-1.mga4
qtbase5
Mageia:4
before 5.2.0-2.3.mga4
5.2.0-2.3.mga4
qt3
Mageia:3
before 3.3.8b-32.1.mga3
3.3.8b-32.1.mga3
qt3
Mageia:4
before 3.3.8b-33.2.mga4
3.3.8b-33.2.mga4
qt4-x11
Ubuntu:14.04:LTS
before 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1, plus listed versions
4:4.8.4+dfsg-0ubuntu184:4.8.4+dfsg-0ubuntu194:4.8.4+dfsg-0ubuntu204:4.8.4+dfsg-0ubuntu214:4.8.4+dfsg-0ubuntu224:4.8.5+git192-g085f851+dfsg-2ubuntu34:4.8.5+git192-g085f851+dfsg-2ubuntu4
4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
qtbase-opensource-src
Ubuntu:14.04:LTS
before 5.2.1+dfsg-1ubuntu14.3, plus listed versions
5.0.2+dfsg1-7ubuntu115.0.2+dfsg1-7ubuntu125.0.2+dfsg1-7ubuntu135.0.2+dfsg1-7ubuntu145.0.2+dfsg1-7ubuntu15
Show 11 moreShow less
5.0.2+dfsg1-7ubuntu165.0.2+dfsg1-7ubuntu175.0.2+dfsg1-7ubuntu185.2.1+dfsg-1ubuntu75.2.1+dfsg-1ubuntu85.2.1+dfsg-1ubuntu95.2.1+dfsg-1ubuntu105.2.1+dfsg-1ubuntu115.2.1+dfsg-1ubuntu135.2.1+dfsg-1ubuntu145.2.1+dfsg-1ubuntu14.2
5.2.1+dfsg-1ubuntu14.3

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 34 moreShow less
MoveEnter Open