Every CVE Search/ Get API key

CVE-2014-0593

sed command injection

7.8 HighFix available

The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.87%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.8

sed command injection

The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.

Record
CVE-2014-0593
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
EUVDEUVD-2014-0624 7.8

The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.

Record
EUVD-2014-0624
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-h8fh-v5gw-ch7g 9.8

The set_version script as shipped with obs-service-set_version is a source validator for the Open...

The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.

Record
GHSA-h8fh-v5gw-ch7g
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
NVD 7.8

The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.

Record
CVE-2014-0593
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-78, CWE-20
Updated
2026-11-02
OSVopenSUSE-SU-2024:10108-1 No score

obs-service-set_version-0.5.3-4.2 on GA media

These are all security issues fixed in the obs-service-set_version-0.5.3-4.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10108-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
obs-service-set_version
openSUSE:Tumbleweed
before 0.5.3-4.2
0.5.3-4.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0593 is a high vulnerability (CVSS 7.8) in Opensuse Open Build Service, published June 8, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.87%, the 79th percentile. Fixed in obs-service-set_version 0.5.3-4.2.

References

MoveEnter Open