CVE-2014-10065
Content Injection in remarkable
Certain input when passed into remarkable before 1.4.1 will bypass the bad protocol check that disallows the javascript: scheme allowing for javascript: url's to be injected into the rendered content.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Certain input when passed into remarkable before 1.4.1 will bypass the bad protocol check that disallows the javascript: scheme allowing for javascript: url's to be injected into the rendered content.
- Record
CVE-2014-10065- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-94, CWE-79
- Updated
- 2026-11-02
CVE List No score
Certain input when passed into remarkable before 1.4.1 will bypass the bad protocol check that disallows the javascript: scheme allowing for javascript: url's to be injected into the rendered content.
- Record
CVE-2014-10065- Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2020-0620 No score
Certain input when passed into remarkable before 1.4.1 will bypass the bad protocol check that disallows the javascript: scheme allowing for javascript: url's to be injected into the rendered content.
- Record
EUVD-2020-0620- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f9vc-q3hh-qhfv No score
Content Injection in remarkable
Versions 1.4.0 and earlier of remarkable are affected by a cross-site scripting vulnerability. This occurs because vulnerable versions of remarkable did not properly whitelist link protocols, and consequently allowed javascript: to be used.
Proof of Concept
Markdown Source:
[link](<javascript:alert(1)>)
Rendered HTML:
<a href="javascript:alert(1)">link</a>
Recommendation
Update to version 1.4.1 or later
- Record
GHSA-f9vc-q3hh-qhfv- Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-f9vc-q3hh-qhfv No score
Content Injection in remarkable
Versions 1.4.0 and earlier of remarkable are affected by a cross-site scripting vulnerability. This occurs because vulnerable versions of remarkable did not properly whitelist link protocols, and consequently allowed javascript: to be used.
Proof of Concept
Markdown Source:
[link](<javascript:alert(1)>)
Rendered HTML:
<a href="javascript:alert(1)">link</a>
Recommendation
Update to version 1.4.1 or later
- Record
GHSA-f9vc-q3hh-qhfv- Weakness
- CWE-94
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
remarkablenpm |
before 1.4.1 | 1.4.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-10065 is a medium vulnerability (CVSS 6.1) in Remarkable Project Remarkable, published May 31, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.96%, the 61st percentile. Fixed in remarkable 1.4.1.