Every CVE Search/ Get API key

CVE-2014-10077

i18n Vulnerable to Denial of Service Attack

7.5 HighFix available

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.39%Up 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
CVE-2014-10077
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
CVE-2014-10077
Updated
2026-11-02
EUVDEUVD-2022-2105 No score

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
EUVD-2022-2105
Updated
2026-11-03
GitHub AdvisoriesGHSA-34hf-g744-jw64 7.5

i18n Vulnerable to Denial of Service Attack

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
GHSA-34hf-g744-jw64
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 7.5

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
CVE-2014-10077
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-10077 7.5

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
DEBIAN-CVE-2014-10077
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-34hf-g744-jw64 7.5

i18n Vulnerable to Denial of Service Attack

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
GHSA-34hf-g744-jw64
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2014-10077 7.5

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Record
UBUNTU-CVE-2014-10077
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0491 No score

Updated ruby-i18n packages fix security vulnerability

A flaw was found in the i18n gem before 0.8.0 for Ruby. The Hash#slice in lib/i18n/core_ext/hash.rb allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash (CVE-2014-10077).

Record
MGASA-2018-0491
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
i18n
RubyGems
before 0.8.0
0.8.0
ruby-i18n
Debian:12
before 0.7.0-3
0.7.0-3
ruby-i18n
Debian:13
before 0.7.0-3
0.7.0-3
ruby-i18n
Debian:14
before 0.7.0-3
0.7.0-3
ruby-i18n
Debian:8
before 0.6.9-2+deb8u1, plus listed versions
0.6.9-2
0.6.9-2+deb8u1
i18n
RubyGems
before 0.8.0, plus listed versions
0.1.00.2.00.2.10.3.00.3.1
Show 32 moreShow less
0.3.20.3.30.3.40.3.50.3.60.3.6.pre0.3.70.4.00.4.0.beta0.4.0.beta10.4.10.4.20.5.00.5.0beta10.5.0beta20.5.0beta30.5.20.5.30.5.40.6.00.6.0beta10.6.10.6.110.6.20.6.30.6.40.6.50.6.80.6.90.7.00.7.0.beta10.8.0.beta1
0.8.0
ruby-i18n
Mageia:6
before 0.7.0-1.1.mga6
0.7.0-1.1.mga6
ruby-i18n
Ubuntu:Pro:14.04:LTS
before 0.6.9-2+deb8u1build0.14.04.1~esm1, plus listed versions
0.6.4-10.6.5-10.6.9-1
0.6.9-2+deb8u1build0.14.04.1~esm1
ruby-i18n
Ubuntu:16.04:LTS
All versions, plus listed versions
0.6.11-20.7.0-2
None known
ruby-i18n
Ubuntu:18.04:LTS
All versions, plus listed versions
0.7.0-2
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-10077 is a high vulnerability (CVSS 7.5) in I18n Project I18n, published November 6, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.39%, the 88th percentile. Fixed in i18n 0.8.0.

References

Show 9 moreShow less
MoveEnter Open