Every CVE Search/ Get API key

CVE-2014-1385

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to...

6.8 MediumFix available

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in HT6367.

Exploit likelihood

2.76%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in HT6367.

Record
CVE-2014-1385
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in HT6367.

Record
CVE-2014-1385
Updated
2026-11-02
EUVDEUVD-2014-1463 No score

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in HT6367.

Record
EUVD-2014-1463
Updated
2026-11-03
GitHub AdvisoriesGHSA-jhpp-3622-4ffr No score

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to...

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in HT6367.

Record
GHSA-jhpp-3622-4ffr
Weakness
CWE-119
Updated
2026-11-02
OSVopenSUSE-SU-2024:10461-1 No score

libjavascriptcoregtk-1_0-0-2.4.11-3.3 on GA media

These are all security issues fixed in the libjavascriptcoregtk-1_0-0-2.4.11-3.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10461-1
Updated
2026-11-02
OSVSUSE-SU-2015:0688-1 No score

Security update for webkitgtk

This update fixes the following security issues:

  • Fix SSL connection issues with some websites after the POODLE vulnerability fix.
  • Fix a crash when loading flash plugins.
  • Fix build on GNU Hurd - Fix build on OS X.
  • Fix documentation of webkit_print_operation_get_page_setup().
  • Security fixes: CVE-2014-1344, CVE-2014-1384, CVE-2014-1385, CVE-2014-1386, CVE-2014-1387, CVE-2014-1388, CVE-2014-1389, CVE-2014-1390, CVE-2015-2330. (bnc#879607, bnc#871792)
  • Pass autoreconf and enable libtool BuildRequires: Needed for above patch since it touches the buildsystem.
  • Bugs fixed: boo#871792, boo#879607 and boo#879607.
Record
SUSE-SU-2015:0688-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-1385 No score

WebKit, as used in Apple Safari before 6.1.6 and 7.x before 7.0.6, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site, a different vulnerability than other WebKit CVEs listed in HT6367.

Record
UBUNTU-CVE-2014-1385
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webkitgtk
SUSE:Linux Enterprise Desktop 12
before 2.4.8-16.2
2.4.8-16.2
webkitgtk3
SUSE:Linux Enterprise Desktop 12
before 2.4.8-16.2
2.4.8-16.2
webkitgtk
SUSE:Linux Enterprise Software Development Kit 12
before 2.4.8-16.2
2.4.8-16.2
webkitgtk3
SUSE:Linux Enterprise Software Development Kit 12
before 2.4.8-16.2
2.4.8-16.2
webkitgtk3
SUSE:Linux Enterprise Server 12
before 2.4.8-16.2
2.4.8-16.2
webkitgtk3
SUSE:Linux Enterprise Server for SAP Applications 12
before 2.4.8-16.2
2.4.8-16.2
webkitgtk
SUSE:Linux Enterprise Workstation Extension 12
before 2.4.8-16.2
2.4.8-16.2
webkitgtk3
SUSE:Linux Enterprise Workstation Extension 12
before 2.4.8-16.2
2.4.8-16.2
qtwebkit-opensource-src
Ubuntu:16.04:LTS
All versions, plus listed versions
5.4.2+dfsg-1ubuntu2.15.5.1+dfsg-2ubuntu1
None known
qtwebkit-source
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.2-0ubuntu102.3.2-0ubuntu11
None known
gtk3
openSUSE:Tumbleweed
before 2.4.11-3.3
2.4.11-3.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-1385 is a medium vulnerability (CVSS 6.8) in Apple Safari, published August 14, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.76%, the 86th percentile. Fixed in webkitgtk 2.4.8-16.2.

References

Show 53 moreShow less
MoveEnter Open