CVE-2014-1424
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows...
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows attackers to bypass AppArmor policies via unspecified vectors, related to a "miscompilation flaw."
Exploit likelihood
What each source reports
NVD Score used
6.4
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows attackers to bypass AppArmor policies via unspecified vectors, related to a "miscompilation flaw."
- Record
CVE-2014-1424- CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:P - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows attackers to bypass AppArmor policies via unspecified vectors, related to a "miscompilation flaw."
- Record
CVE-2014-1424- Updated
- 2026-11-02
EUVDEUVD-2014-1500 No score
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows attackers to bypass AppArmor policies via unspecified vectors, related to a "miscompilation flaw."
- Record
EUVD-2014-1500- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fq7h-8mv4-76qc No score
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows...
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows attackers to bypass AppArmor policies via unspecified vectors, related to a "miscompilation flaw."
- Record
GHSA-fq7h-8mv4-76qc- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-1424 No score
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows attackers to bypass AppArmor policies via unspecified vectors, related to a "miscompilation flaw."
- Record
UBUNTU-CVE-2014-1424- Updated
- 2026-11-02
OSVUSN-2413-1 No score
apparmor vulnerability
An AppArmor policy miscompilation flaw was discovered in apparmor_parser. Under certain circumstances, a malicious application could use this flaw to perform operations that are not allowed by AppArmor policy. The flaw may also prevent applications from accessing resources that are allowed by AppArmor policy.
- Record
USN-2413-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apparmorUbuntu:14.04:LTS |
before 2.8.95~2430-0ubuntu5.1, plus listed versions 2.8.0-0ubuntu312.8.0-0ubuntu322.8.0-0ubuntu332.8.0-0ubuntu342.8.0-0ubuntu35 Show 6 moreShow less2.8.0-0ubuntu372.8.0-0ubuntu382.8.95~2430-0ubuntu12.8.95~2430-0ubuntu22.8.95~2430-0ubuntu32.8.95~2430-0ubuntu5 |
2.8.95~2430-0ubuntu5.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-1424 is a medium vulnerability (CVSS 6.4) in Canonical Ubuntu, published November 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in apparmor 2.8.95~2430-0ubuntu5.1.