Every CVE Search/ Get API key

CVE-2014-1868

Moderate severity vulnerability that affects org.restlet.jse:org.restlet

5.0 MediumFix available

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Exploit likelihood

1.34%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Record
CVE-2014-1868
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Record
CVE-2014-1868
Updated
2026-11-02
EUVDEUVD-2018-0530 No score

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Record
EUVD-2018-0530
Updated
2026-11-03
GitHub AdvisoriesGHSA-73cq-fhp3-8rpw No score

Moderate severity vulnerability that affects org.restlet.jse:org.restlet

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Record
GHSA-73cq-fhp3-8rpw
Weakness
CWE-776
Updated
2026-11-02
OSVGHSA-73cq-fhp3-8rpw No score

Moderate severity vulnerability that affects org.restlet.jse:org.restlet

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Record
GHSA-73cq-fhp3-8rpw
Weakness
CWE-776
Updated
2026-11-02
OSVUBUNTU-CVE-2014-1868 No score

Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

Record
UBUNTU-CVE-2014-1868
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.restlet.jse:org.restlet
Maven
2.1.0 up to 2.1.7
2.1.7
restlet
Ubuntu:16.04:LTS
All versions, plus listed versions
2.0.14+repack-0ubuntu1
None known
restlet
Ubuntu:18.04:LTS
All versions, plus listed versions
2.0.14+repack-0ubuntu1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-1868 is a medium vulnerability (CVSS 5.0) in Restlet Framework, published October 6, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.34%, the 71st percentile. Fixed in org.restlet.jse:org.restlet 2.1.7.

References

MoveEnter Open