Every CVE Search/ Get API key

CVE-2014-1879

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote...

3.5 LowFix available

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Exploit likelihood

0.97%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Record
CVE-2014-1879
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Record
CVE-2014-1879
Updated
2026-11-02
EUVDEUVD-2014-1941 No score

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Record
EUVD-2014-1941
Updated
2026-11-03
GitHub AdvisoriesGHSA-6m6g-jfj8-2gh7 No score

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote...

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Record
GHSA-6m6g-jfj8-2gh7
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Record
CVE-2014-1879
Updated
2026-11-02
OSVDEBIAN-CVE-2014-1879 No score

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Record
DEBIAN-CVE-2014-1879
Updated
2026-11-02
OSVMGASA-2014-0099 No score

Updated phpseclib and phpmyadmin packages fix security vulnerability

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action (CVE-2014-1879).

This upgrade provides the latest phpmyadmin version (4.1.8) to address this vulnerability.

Additionally the phpseclib package has been added in Mageia 3 and updated in Mageia 4, due to new dependencies.

Record
MGASA-2014-0099
Updated
2026-11-02
OSVopenSUSE-SU-2024:10054-1 No score

phpMyAdmin-4.6.5.2-1.1 on GA media

These are all security issues fixed in the phpMyAdmin-4.6.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10054-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-1879 No score

Cross-site scripting (XSS) vulnerability in import.php in phpMyAdmin before 4.1.7 allows remote authenticated users to inject arbitrary web script or HTML via a crafted filename in an import action.

Record
UBUNTU-CVE-2014-1879
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin
Debian:12
before 4:4.1.7-1
4:4.1.7-1
phpmyadmin
Debian:13
before 4:4.1.7-1
4:4.1.7-1
phpmyadmin
Debian:14
before 4:4.1.7-1
4:4.1.7-1
phpmyadmin
Debian:7
From an advisory covering 5 CVEs
before 4:3.4.11.1-2+deb7u1, plus listed versions
4:3.4.11.1-2
4:3.4.11.1-2+deb7u1
phpseclib
Mageia:3
before 0.3.5-1.mga3
0.3.5-1.mga3
phpmyadmin
Mageia:3
before 4.1.8-1.mga3
4.1.8-1.mga3
phpseclib
Mageia:4
before 0.3.5-1.mga4
0.3.5-1.mga4
phpmyadmin
Mageia:4
before 4.1.8-1.mga4
4.1.8-1.mga4
phpmyadmin
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
4:4.0.6-14:4.0.8-14:4.0.9-14:4.0.10-14:4.0.10-1ubuntu0.1
Show 4 moreShow less
4:4.0.10-1ubuntu0.1+esm14:4.0.10-1ubuntu0.1+esm24:4.0.10-1ubuntu0.1+esm34:4.0.10-1ubuntu0.1+esm4
None known
phpMyAdmin
openSUSE:Tumbleweed
From an advisory covering 124 CVEs
before 4.6.5.2-1.1
4.6.5.2-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-1879 is a low vulnerability (CVSS 3.5) in Phpmyadmin, published February 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.97%, the 62nd percentile. Fixed in phpmyadmin 4:4.1.7-1.

References

Show 131 moreShow less
MoveEnter Open