CVE-2014-1929
python-gnupg vulnerable to shell injection
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
Exploit likelihood
What each source reports
NVD Score used
4.4
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
CVE-2014-1929- CVSS 2.0
- 4.4 Medium
AV:L/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
CVE-2014-1929- Updated
- 2026-11-02
EUVDEUVD-2014-0090 No score
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
EUVD-2014-0090- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vcr5-xr9h-mvc5
9.3
python-gnupg vulnerable to shell injection
python-gnupg 0.3.5 and 0.3.6 allow for shell injection via a failure to escape backslashes in the shell_quote() function. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
GHSA-vcr5-xr9h-mvc5- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-vcr5-xr9h-mvc5
9.3
python-gnupg vulnerable to shell injection
python-gnupg 0.3.5 and 0.3.6 allow for shell injection via a failure to escape backslashes in the shell_quote() function. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
GHSA-vcr5-xr9h-mvc5- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
CVE-2014-1929- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-1929 No score
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
DEBIAN-CVE-2014-1929- Updated
- 2026-11-02
OSVPYSEC-2014-92 No score
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
PYSEC-2014-92- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-1929 No score
python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
- Record
UBUNTU-CVE-2014-1929- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-gnupgPyPI |
0.3.5 to 0.3.6 | 0.3.7 |
python-gnupgDebian:12 |
before 0.3.6-1 | 0.3.6-1 |
python-gnupgDebian:13 |
before 0.3.6-1 | 0.3.6-1 |
python-gnupgDebian:14 |
before 0.3.6-1 | 0.3.6-1 |
python-gnupgDebian:7 |
before 0.3.6-1~deb7u1, plus listed versions 0.3.0-1.10.3.4-10.3.5-10.3.5-2 |
0.3.6-1~deb7u1 |
python-gnupgPyPI |
0.3.5 up to 0.3.7, plus listed versions 0.3.6 |
0.3.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-1929 is a medium vulnerability (CVSS 4.4) in Python-gnupg Project Python-gnupg, published June 4, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 32nd percentile. Fixed in python-gnupg 0.3.7.
References
debian.org/security/2014/dsa-2946
seclists.org/oss-sec/2014/q1/245
seclists.org/oss-sec/2014/q1/335
secunia.com/advisories/59031
nvd.nist.gov/vuln/detail/CVE-2014-1929
github.com/advisories/GHSA-vcr5-xr9h-mvc5
Show 12 moreShow less
alioth-lists.debian.net/pipermail/debian-security-tracker-commits/2014-June/028512.html
code.google.com/archive/p/python-gnupg/issues/98
web.archive.org/web/20200228170437/http://www.securityfocus.com/bid/65539
openwall.com/lists/oss-security/2014/02/04/3
openwall.com/lists/oss-security/2014/02/04/4
github.com/pypa/advisory-database/tree/main/vulns/python-gnupg/PYSEC-2014-92.yaml
security-tracker.debian.org/tracker/CVE-2014-1929
github.com/vsajip/python-gnupg
ubuntu.com/security/CVE-2014-1929
openwall.com/lists/oss-security/2014/02/06/5
openwall.com/lists/oss-security/2014/02/12/15
cve.org/CVERecord?id=CVE-2014-1929