CVE-2014-2323
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote...
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
- Record
CVE-2014-2323- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
- Record
CVE-2014-2323- Updated
- 2026-11-02
EUVDEUVD-2014-2360 No score
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
- Record
EUVD-2014-2360- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v97w-2rqc-4p78
9.8
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote...
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
- Record
GHSA-v97w-2rqc-4p78- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
9.8
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
- Record
CVE-2014-2323- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-2323
9.8
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
- Record
DEBIAN-CVE-2014-2323- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-2323
9.8
SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.
- Record
UBUNTU-CVE-2014-2323- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2014-0133 No score
Updated lighttpd package fixes security vulnerabilities
SQL injection vulnerability in lighttpd before 1.4.35 when mod_mysql_vhost is in use, due to insufficient validation of hostnames in HTTP requests (CVE-2014-2323).
Possible path traversal vulnerabilities in lighttpd before 1.4.35 when either mod_evhost or mod_simple_vhost are in use, due to insufficient validation of hostnames in HTTP requests (CVE-2014-2324).
- Record
MGASA-2014-0133- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10402-1 No score
lighttpd-1.4.37-1.6 on GA media
These are all security issues fixed in the lighttpd-1.4.37-1.6 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10402-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lighttpdDebian:12 |
before 1.4.33-1+nmu3 | 1.4.33-1+nmu3 |
lighttpdDebian:13 |
before 1.4.33-1+nmu3 | 1.4.33-1+nmu3 |
lighttpdDebian:14 |
before 1.4.33-1+nmu3 | 1.4.33-1+nmu3 |
lighttpdDebian:6.0 |
before 1.4.28-2+squeeze1.6, plus listed versions 1.4.28-21.4.28-2+squeeze11.4.28-2+squeeze1.11.4.28-2+squeeze1.21.4.28-2+squeeze1.31.4.28-2+squeeze1.41.4.28-2+squeeze1.5 |
1.4.28-2+squeeze1.6 |
lighttpdDebian:7 |
before 1.4.31-4+deb7u3, plus listed versions 1.4.31-41.4.31-4+deb7u11.4.31-4+deb7u2 |
1.4.31-4+deb7u3 |
lighttpdMageia:3 |
before 1.4.32-3.7.mga3 | 1.4.32-3.7.mga3 |
lighttpdMageia:4 |
before 1.4.33-4.1.mga4 | 1.4.33-4.1.mga4 |
lighttpdUbuntu:14.04:LTS |
before 1.4.33-1+nmu2ubuntu2.1, plus listed versions 1.4.31-3ubuntu31.4.33-1ubuntu11.4.33-1+nmu2ubuntu11.4.33-1+nmu2ubuntu2 |
1.4.33-1+nmu2ubuntu2.1 |
lighttpdopenSUSE:Tumbleweed |
before 1.4.37-1.6 | 1.4.37-1.6 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | Lighttpd 1.4.34 SQL Injection and Path Traversal | |
| PoC in GitHub | cirocosta/lighty-sqlinj-demo | 2015-10-08 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-2323 is a critical vulnerability (CVSS 9.8) in Lighttpd, published March 12, 2014. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 62.8%, the 99th percentile. Fixed in lighttpd 1.4.33-1+nmu3.
References
lighttpd.net/2014/3/12/1.4.35
download.lighttpd.net/lighttpd/security/lighttpd_sa_2014_01.txt
debian.org/security/2014/dsa-2877
lists.opensuse.org/opensuse-security-announce/2014-03/msg00023.html
secunia.com/advisories/57514
marc.info?l=bugtraq&m=141576815022399&w=2
Show 22 moreShow less
lists.opensuse.org/opensuse-security-announce/2014-04/msg00006.html
lists.opensuse.org/opensuse-security-announce/2014-04/msg00002.html
secunia.com/advisories/57404
seclists.org/oss-sec/2014/q1/564
seclists.org/oss-sec/2014/q1/561
jvn.jp/en/jp/JVN37417423/index.html
nvd.nist.gov/vuln/detail/CVE-2014-2323
github.com/advisories/GHSA-v97w-2rqc-4p78
security-tracker.debian.org/tracker/CVE-2014-2323
advisories.mageia.org/MGASA-2014-0133.html
bugs.mageia.org/show_bug.cgi?id=13003
openwall.com/lists/oss-security/2014/03/12/12
ubuntu.com/security/CVE-2014-2323
cve.org/CVERecord?id=CVE-2014-2323
suse.com/security/cve/CVE-2010-0295
suse.com/security/cve/CVE-2011-4362
suse.com/security/cve/CVE-2012-5533
suse.com/security/cve/CVE-2013-4508
suse.com/security/cve/CVE-2013-4559
suse.com/security/cve/CVE-2013-4560
suse.com/security/cve/CVE-2014-2323
suse.com/security/cve/CVE-2014-2324