Every CVE Search/ Get API key

CVE-2014-2324

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in...

5.0 MediumPublic exploitFix available

CVE-2014-2324 is a medium vulnerability (CVSS 5.0) in Lighttpd, published March 12, 2014. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 29.5%, the 98th percentile. Fixed in lighttpd 1.4.33-1+nmu3.

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Exploit likelihood

29.5%Down 7.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Record
CVE-2014-2324
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Record
CVE-2014-2324
Updated
2026-11-02
EUVDEUVD-2014-2361 No score

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Record
EUVD-2014-2361
Updated
2026-11-03
GitHub AdvisoriesGHSA-mvq4-g5jc-x2wr No score

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in...

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Record
GHSA-mvq4-g5jc-x2wr
Weakness
CWE-22
Updated
2026-11-02
OSV No score

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Record
CVE-2014-2324
Updated
2026-11-02
OSVDEBIAN-CVE-2014-2324 No score

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Record
DEBIAN-CVE-2014-2324
Updated
2026-11-02
OSVMGASA-2014-0133 No score

Updated lighttpd package fixes security vulnerabilities

SQL injection vulnerability in lighttpd before 1.4.35 when mod_mysql_vhost is in use, due to insufficient validation of hostnames in HTTP requests (CVE-2014-2323).

Possible path traversal vulnerabilities in lighttpd before 1.4.35 when either mod_evhost or mod_simple_vhost are in use, due to insufficient validation of hostnames in HTTP requests (CVE-2014-2324).

Record
MGASA-2014-0133
Updated
2026-11-02
OSVopenSUSE-SU-2024:10402-1 No score

lighttpd-1.4.37-1.6 on GA media

These are all security issues fixed in the lighttpd-1.4.37-1.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10402-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-2324 No score

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

Record
UBUNTU-CVE-2014-2324
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lighttpd
Debian:12
before 1.4.33-1+nmu3
1.4.33-1+nmu3
lighttpd
Debian:13
before 1.4.33-1+nmu3
1.4.33-1+nmu3
lighttpd
Debian:14
before 1.4.33-1+nmu3
1.4.33-1+nmu3
lighttpd
Debian:6.0
before 1.4.28-2+squeeze1.6, plus listed versions
1.4.28-21.4.28-2+squeeze11.4.28-2+squeeze1.11.4.28-2+squeeze1.21.4.28-2+squeeze1.31.4.28-2+squeeze1.41.4.28-2+squeeze1.5
1.4.28-2+squeeze1.6
lighttpd
Debian:7
before 1.4.31-4+deb7u3, plus listed versions
1.4.31-41.4.31-4+deb7u11.4.31-4+deb7u2
1.4.31-4+deb7u3
lighttpd
Mageia:3
before 1.4.32-3.7.mga3
1.4.32-3.7.mga3
lighttpd
Mageia:4
before 1.4.33-4.1.mga4
1.4.33-4.1.mga4
lighttpd
Ubuntu:14.04:LTS
before 1.4.33-1+nmu2ubuntu2.1, plus listed versions
1.4.31-3ubuntu31.4.33-1ubuntu11.4.33-1+nmu2ubuntu11.4.33-1+nmu2ubuntu2
1.4.33-1+nmu2ubuntu2.1
lighttpd
openSUSE:Tumbleweed
before 1.4.37-1.6
1.4.37-1.6

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubsp4c30x1/uc_httpd_exploit2017-12-30

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

References

Show 23 moreShow less
MoveEnter Open