Every CVE Search/ Get API key

CVE-2014-2583

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for...

5.8 MediumFix available

CVE-2014-2583 is a medium vulnerability (CVSS 5.8) in Linux-pam, published April 10, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.11%, the 90th percentile. Fixed in pam 1.1.8-3.1.

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Exploit likelihood

4.11%Up 2.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Record
CVE-2014-2583
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Record
CVE-2014-2583
Updated
2026-11-02
EUVDEUVD-2014-2615 No score

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Record
EUVD-2014-2615
Updated
2026-11-03
GitHub AdvisoriesGHSA-p526-qhf4-2v4r No score

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for...

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Record
GHSA-p526-qhf4-2v4r
Weakness
CWE-22
Updated
2026-11-02
OSV No score

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Record
CVE-2014-2583
Updated
2026-11-02
OSVDEBIAN-CVE-2014-2583 No score

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Record
DEBIAN-CVE-2014-2583
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2015-0213 No score

Updated pam packages fix security vulnerabilities

Updated pam packages fix security vulnerabilities:

The pam_userdb module for Pam uses a case-insensitive method to compare hashed passwords, which makes it easier for attackers to guess the password via a brute force attack (CVE-2013-7041).

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create aribitrary files or possibly bypass authentication via a .. (dot dot) in the PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty funtion, which is used by the format_timestamp_name function (CVE-2014-2583).

Record
MGASA-2015-0213
Updated
2026-11-02
OSVopenSUSE-SU-2024:10405-1 No score

pam-1.3.0-3.4 on GA media

These are all security issues fixed in the pam-1.3.0-3.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10405-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-2583 No score

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

Record
UBUNTU-CVE-2014-2583
Updated
2026-11-02
OSVUSN-2935-1 No score

pam vulnerabilities

It was discovered that the PAM pam_userdb module incorrectly used a case-insensitive method when comparing hashed passwords. A local attacker could possibly use this issue to make brute force attacks easier. This issue only affected Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2013-7041)

Sebastian Krahmer discovered that the PAM pam_timestamp module incorrectly performed filtering. A local attacker could use this issue to create arbitrary files, or possibly bypass authentication. This issue only affected Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2014-2583)

Sebastien Macke discovered that the PAM pam_unix module incorrectly handled large passwords. A local attacker could possibly use this issue in certain environments to enumerate usernames or cause a denial of service. (CVE-2015-3238)

Record
USN-2935-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pam
Debian:12
before 1.1.8-3.1
1.1.8-3.1
pam
Debian:13
before 1.1.8-3.1
1.1.8-3.1
pam
Debian:14
before 1.1.8-3.1
1.1.8-3.1
pam
Mageia:4
before 1.1.8-7.1.mga4
1.1.8-7.1.mga4
pam
Ubuntu:14.04:LTS
before 1.1.8-1ubuntu2.1, plus listed versions
1.1.3-8ubuntu31.1.3-10ubuntu11.1.3-11ubuntu11.1.8-1ubuntu11.1.8-1ubuntu2
1.1.8-1ubuntu2.1
pam
openSUSE:Tumbleweed
before 1.3.0-3.4
1.3.0-3.4

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 23 moreShow less
MoveEnter Open