Every CVE Search/ Get API key

CVE-2014-2686

Ansible unsafe evaluation of some strings

7.5 HighFix available

CVE-2014-2686 is a high vulnerability (CVSS 7.5) in Redhat Ansible, published January 9, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 67th percentile. Fixed in ansible 1.5.4.

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.19%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
CVE-2014-2686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-670
Updated
2026-11-02
CVE List No score

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
CVE-2014-2686
Updated
2026-11-02
EUVDEUVD-2020-0009 No score

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
EUVD-2020-0009
Updated
2026-11-03
GitHub AdvisoriesGHSA-49m5-2838-q2rv 8.7

Ansible unsafe evaluation of some strings

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
GHSA-49m5-2838-q2rv
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-670
Updated
2026-11-02
OSV 7.5

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
CVE-2014-2686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2014-2686 7.5

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
DEBIAN-CVE-2014-2686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-49m5-2838-q2rv 8.7

Ansible unsafe evaluation of some strings

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
GHSA-49m5-2838-q2rv
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-670
Updated
2026-11-02
OSVUBUNTU-CVE-2014-2686 7.5

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
UBUNTU-CVE-2014-2686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVPYSEC-2020-198 No score

Ansible prior to 1.5.4 mishandles the evaluation of some strings.

Record
PYSEC-2020-198
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ansible
PyPI
before 1.5.4
1.5.4
ansible
Debian:12
before 1.5.4+dfsg-1
1.5.4+dfsg-1
ansible
Debian:13
before 1.5.4+dfsg-1
1.5.4+dfsg-1
ansible
Debian:14
before 1.5.4+dfsg-1
1.5.4+dfsg-1
ansible
PyPI
before 1.5.4, plus listed versions
1.01.11.21.2.11.2.2
Show 16 moreShow less
1.2.31.3.01.3.11.3.21.3.31.3.41.41.4.11.4.21.4.31.4.41.4.51.51.5.11.5.21.5.3
1.5.4

History

History
WhenChangedSources
2026-11-03affected
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open