Every CVE Search/ Get API key

CVE-2014-2707

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary...

8.3 HighFix available

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Exploit likelihood

1.17%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.3

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Record
CVE-2014-2707
CVSS 2.0
8.3 HighAV:A/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-78
Updated
2026-11-02
CVE List No score

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Record
CVE-2014-2707
Updated
2026-11-02
EUVDEUVD-2014-2735 No score

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Record
EUVD-2014-2735
Updated
2026-11-03
GitHub AdvisoriesGHSA-cc2p-9m5r-9hc8 No score

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary...

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Record
GHSA-cc2p-9m5r-9hc8
Weakness
CWE-78
Updated
2026-11-02
OSV No score

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Record
CVE-2014-2707
Updated
2026-11-02
OSVDEBIAN-CVE-2014-2707 No score

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Record
DEBIAN-CVE-2014-2707
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0181 No score

Updated cups-filters packages fix security vulnerability

Updated cups-filters packages fix security vulnerability:

Sebastian Krahmer discovered it was possible to use malicious broadcast packets to execute arbitrary commands on a server running the cups- browsed daemon (CVE-2014-2707).

Note that only systems that have enabled the affected feature by using the CreateIPPPrinterQueues configuration directive in /etc/cups/cups- browsed.conf are affected.

Record
MGASA-2014-0181
Updated
2026-11-02
OSVopenSUSE-SU-2024:10313-1 No score

cups-filters-1.8.2-1.11 on GA media

These are all security issues fixed in the cups-filters-1.8.2-1.11 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10313-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-2707 No score

cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP printers to execute arbitrary commands via shell metacharacters in the (1) model or (2) PDL, related to "System V interface scripts generated for queues."

Record
UBUNTU-CVE-2014-2707
Updated
2026-11-02
OSVUSN-2210-1 No score

cups-filters vulnerability

Sebastian Krahmer discovered that cups-browsed incorrectly filtered remote printer names and strings. A remote attacker could use this issue to possibly execute arbitrary commands. (CVE-2014-2707)

Johannes Meixner discovered that cups-browsed ignored invalid BrowseAllow directives. This could cause it to accept browse packets from all hosts, contrary to intended configuration.

Record
USN-2210-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cups-filters
Debian:12
before 1.0.51-1
1.0.51-1
cups-filters
Debian:13
before 1.0.51-1
1.0.51-1
cups-filters
Debian:14
before 1.0.51-1
1.0.51-1
cups-filters
Mageia:4
before 1.0.41-3.4.mga4
1.0.41-3.4.mga4
cups-filters
Ubuntu:14.04:LTS
before 1.0.52-0ubuntu1.1, plus listed versions
1.0.40-0ubuntu11.0.40-0ubuntu21.0.41-0ubuntu11.0.41-21.0.42-1
Show 13 moreShow less
1.0.42-21.0.43-11.0.44-11.0.44-21.0.45-11.0.46-0ubuntu11.0.47-0ubuntu11.0.48-0ubuntu11.0.48-0ubuntu21.0.49-0ubuntu11.0.50-0ubuntu11.0.51-0ubuntu11.0.52-0ubuntu1
1.0.52-0ubuntu1.1
cups-filters
openSUSE:Tumbleweed
From an advisory covering 13 CVEs
before 1.8.2-1.11
1.8.2-1.11

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-2707 is a high vulnerability (CVSS 8.3) in Linuxfoundation Cups-filters, published April 17, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.17%, the 67th percentile. Fixed in cups-filters 1.0.51-1.

References

Show 23 moreShow less
MoveEnter Open