Every CVE Search/ Get API key

CVE-2014-2708

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier...

7.5 HighFix available

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Exploit likelihood

1.92%Down 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Record
CVE-2014-2708
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Record
CVE-2014-2708
Updated
2026-11-02
EUVDEUVD-2014-2736 No score

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Record
EUVD-2014-2736
Updated
2026-11-03
GitHub AdvisoriesGHSA-8975-c5xr-xccw No score

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier...

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Record
GHSA-8975-c5xr-xccw
Weakness
CWE-89
Updated
2026-11-02
OSV No score

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Record
CVE-2014-2708
Updated
2026-11-02
OSVDEBIAN-CVE-2014-2708 No score

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Record
DEBIAN-CVE-2014-2708
Updated
2026-11-02
OSVMGASA-2014-0302 No score

Updated cacti package fixes security vulnerabilities

Multiple security issues (cross-site scripting, cross-site request forgery, SQL injections, missing input sanitising) have been found in Cacti (CVE-2014-2326, CVE-2014-2328, CVE-2014-2708, CVE-2014-2709, CVE-2014-4002).

Record
MGASA-2014-0302
Updated
2026-11-02
OSVopenSUSE-SU-2024:10084-1 No score

cacti-0.8.8h-1.2 on GA media

These are all security issues fixed in the cacti-0.8.8h-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10084-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-2708 No score

Multiple SQL injection vulnerabilities in graph_xport.php in Cacti 0.8.7g, 0.8.8b, and earlier allow remote attackers to execute arbitrary SQL commands via the (1) graph_start, (2) graph_end, (3) graph_height, (4) graph_width, (5) graph_nolegend, (6) print_source, (7) local_graph_id, or (8) rra_id parameter.

Record
UBUNTU-CVE-2014-2708
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cacti
Debian:12
before 0.8.8b+dfsg-4
0.8.8b+dfsg-4
cacti
Debian:13
before 0.8.8b+dfsg-4
0.8.8b+dfsg-4
cacti
Debian:14
before 0.8.8b+dfsg-4
0.8.8b+dfsg-4
cacti
Debian:7
From an advisory covering 6 CVEs
before 0.8.8a+dfsg-5+deb7u3, plus listed versions
0.8.8a+dfsg-50.8.8a+dfsg-5+deb7u10.8.8a+dfsg-5+deb7u2
0.8.8a+dfsg-5+deb7u3
cacti
Mageia:4
From an advisory covering 5 CVEs
before 0.8.8b-3.1.mga4
0.8.8b-3.1.mga4
cacti
openSUSE:Tumbleweed
From an advisory covering 18 CVEs
before 0.8.8h-1.2
0.8.8h-1.2

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-2708 is a high vulnerability (CVSS 7.5) in Cacti, published April 10, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 80th percentile. Fixed in cacti 0.8.8b+dfsg-4.

References

Show 33 moreShow less
MoveEnter Open