CVE-2014-2709
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary...
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
Exploit likelihood
What each source reports
NVD Score used
7.5
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
- Record
CVE-2014-2709- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
- Record
CVE-2014-2709- Updated
- 2026-11-02
EUVDEUVD-2014-2737 No score
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
- Record
EUVD-2014-2737- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f4fj-5r86-7vv3 No score
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary...
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
- Record
GHSA-f4fj-5r86-7vv3- Updated
- 2026-11-02
OSV No score
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
- Record
CVE-2014-2709- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-2709 No score
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
- Record
DEBIAN-CVE-2014-2709- Updated
- 2026-11-02
OSVMGASA-2014-0302 No score
Updated cacti package fixes security vulnerabilities
Multiple security issues (cross-site scripting, cross-site request forgery, SQL injections, missing input sanitising) have been found in Cacti (CVE-2014-2326, CVE-2014-2328, CVE-2014-2708, CVE-2014-2709, CVE-2014-4002).
- Record
MGASA-2014-0302- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10084-1 No score
cacti-0.8.8h-1.2 on GA media
These are all security issues fixed in the cacti-0.8.8h-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10084-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-2709 No score
lib/rrd.php in Cacti 0.8.7g, 0.8.8b, and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
- Record
UBUNTU-CVE-2014-2709- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cactiDebian:12 |
before 0.8.8b+dfsg-4 | 0.8.8b+dfsg-4 |
cactiDebian:13 |
before 0.8.8b+dfsg-4 | 0.8.8b+dfsg-4 |
cactiDebian:14 |
before 0.8.8b+dfsg-4 | 0.8.8b+dfsg-4 |
cactiDebian:7 From an advisory covering 6 CVEs |
before 0.8.8a+dfsg-5+deb7u3, plus listed versions 0.8.8a+dfsg-50.8.8a+dfsg-5+deb7u10.8.8a+dfsg-5+deb7u2 |
0.8.8a+dfsg-5+deb7u3 |
cactiMageia:4 From an advisory covering 5 CVEs |
before 0.8.8b-3.1.mga4 | 0.8.8b-3.1.mga4 |
cactiopenSUSE:Tumbleweed From an advisory covering 18 CVEs |
before 0.8.8h-1.2 | 0.8.8h-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-2709 is a high vulnerability (CVSS 7.5) in Cacti, published April 23, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.05%, the 92nd percentile. Fixed in cacti 0.8.8b+dfsg-4.
References
lists.fedoraproject.org/pipermail/package-announce/2014-April/131821.html
bugs.debian.org/cgi-bin/bugreport.cgi?bug=742768
securityfocus.com/bid/66630
svn.cacti.net/viewvc?view=rev&revision=7439
secunia.com/advisories/59203
lists.fedoraproject.org/pipermail/package-announce/2014-April/131842.html
Show 31 moreShow less
seclists.org/oss-sec/2014/q2/15
secunia.com/advisories/57647
debian.org/security/2014/dsa-2970
security.gentoo.org/glsa/201509-03
nvd.nist.gov/vuln/detail/CVE-2014-2709
github.com/advisories/GHSA-f4fj-5r86-7vv3
security-tracker.debian.org/tracker/CVE-2014-2709
advisories.mageia.org/MGASA-2014-0302.html
bugs.mageia.org/show_bug.cgi?id=13626
ubuntu.com/security/CVE-2014-2709
bugs.cacti.net/view.php?id=2405
openwall.com/lists/oss-security/2014/04/03
cve.org/CVERecord?id=CVE-2014-2709
suse.com/security/cve/CVE-2013-5588
suse.com/security/cve/CVE-2013-5589
suse.com/security/cve/CVE-2014-2326
suse.com/security/cve/CVE-2014-2327
suse.com/security/cve/CVE-2014-2328
suse.com/security/cve/CVE-2014-2708
suse.com/security/cve/CVE-2014-2709
suse.com/security/cve/CVE-2014-4002
suse.com/security/cve/CVE-2014-5025
suse.com/security/cve/CVE-2014-5026
suse.com/security/cve/CVE-2015-4342
suse.com/security/cve/CVE-2015-4634
suse.com/security/cve/CVE-2015-8369
suse.com/security/cve/CVE-2015-8377
suse.com/security/cve/CVE-2015-8604
suse.com/security/cve/CVE-2016-2313
suse.com/security/cve/CVE-2016-3172
suse.com/security/cve/CVE-2016-3659