CVE-2014-2744
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4...
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
Exploit likelihood
What each source reports
NVD Score used
7.8
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
- Record
CVE-2014-2744- CVSS 2.0
- 7.8 High
AV:N/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
- Record
CVE-2014-2744- Updated
- 2026-11-02
EUVDEUVD-2014-2771 No score
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
- Record
EUVD-2014-2771- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qx52-4j2j-9hc7 No score
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4...
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
- Record
GHSA-qx52-4j2j-9hc7- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
- Record
CVE-2014-2744- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-2744 No score
plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.
- Record
DEBIAN-CVE-2014-2744- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lua-expatDebian:12 |
before 1.3.0-1 | 1.3.0-1 |
lua-expatDebian:13 |
before 1.3.0-1 | 1.3.0-1 |
lua-expatDebian:14 |
before 1.3.0-1 | 1.3.0-1 |
prosodyDebian:12 |
before 0.9.4-1 | 0.9.4-1 |
prosodyDebian:13 |
before 0.9.4-1 | 0.9.4-1 |
prosodyDebian:14 |
before 0.9.4-1 | 0.9.4-1 |
prosodyDebian:7 |
before 0.8.2-4+deb7u1, plus listed versions 0.8.2-4 |
0.8.2-4+deb7u1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-2744 is a high vulnerability (CVSS 7.8) in Lightwitch Metronome, published April 6, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.31%, the 88th percentile. Fixed in lua-expat 1.3.0-1.