Every CVE Search/ Get API key

CVE-2014-2745

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which...

7.8 HighFix available

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Exploit likelihood

3.14%Up 1.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Record
CVE-2014-2745
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Record
CVE-2014-2745
Updated
2026-11-02
EUVDEUVD-2014-2772 No score

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Record
EUVD-2014-2772
Updated
2026-11-03
GitHub AdvisoriesGHSA-8jhg-7mm6-vg49 No score

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which...

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Record
GHSA-8jhg-7mm6-vg49
Updated
2026-11-02
OSV No score

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Record
CVE-2014-2745
Updated
2026-11-02
OSVDEBIAN-CVE-2014-2745 No score

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Record
DEBIAN-CVE-2014-2745
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
prosody
Debian:12
before 0.9.4-1
0.9.4-1
prosody
Debian:13
before 0.9.4-1
0.9.4-1
prosody
Debian:14
before 0.9.4-1
0.9.4-1
prosody
Debian:7
From an advisory covering 2 CVEs
before 0.8.2-4+deb7u1, plus listed versions
0.8.2-4
0.8.2-4+deb7u1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-2745 is a high vulnerability (CVSS 7.8) in Prosody, published April 6, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.14%, the 87th percentile. Fixed in prosody 0.9.4-1.

References

Show 5 moreShow less
MoveEnter Open