Every CVE Search/ Get API key

CVE-2014-2830

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in...

10.0 HighFix available

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Exploit likelihood

5.61%Up 4.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Record
CVE-2014-2830
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Record
CVE-2014-2830
Updated
2026-11-02
EUVDEUVD-2014-2855 No score

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Record
EUVD-2014-2855
Updated
2026-11-03
GitHub AdvisoriesGHSA-88m7-qhcf-97c3 No score

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in...

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Record
GHSA-88m7-qhcf-97c3
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Record
CVE-2014-2830
Updated
2026-11-02
OSVDEBIAN-CVE-2014-2830 No score

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Record
DEBIAN-CVE-2014-2830
Updated
2026-11-02
OSVMGASA-2014-0242 No score

Updated cifs-utils packages fix CVE-2014-2830

Updated cifs-utils packages fix security vulnerability:

Sebastian Krahmer discovered a stack-based buffer overflow flaw in cifscreds.c (CVE-2014-2830).

Record
MGASA-2014-0242
Updated
2026-11-02
OSVUBUNTU-CVE-2014-2830 No score

Stack-based buffer overflow in cifskey.c or cifscreds.c in cifs-utils before 6.4, as used in pam_cifscreds, allows remote attackers to have unspecified impact via unknown vectors.

Record
UBUNTU-CVE-2014-2830
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cifs-utils
Debian:12
All versions, plus listed versions
2:7.0-22:7.0-2.12:7.1-12:7.2-12:7.2-2
Show 4 moreShow less
2:7.3-12:7.4-12:7.8-12:7.9-1
None known
cifs-utils
Debian:13
All versions, plus listed versions
2:7.4-12:7.4-1+deb13u12:7.4-1+deb13u22:7.8-12:7.9-1
None known
cifs-utils
Debian:14
All versions, plus listed versions
2:7.4-12:7.8-12:7.9-1
None known
cifs-utils
Mageia:3
before 6.0-1.1.mga3
6.0-1.1.mga3
cifs-utils
Mageia:4
before 6.2-2.1.mga4
6.2-2.1.mga4

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-2830 is a high vulnerability (CVSS 10.0) in Debian Cifs-utils, published May 29, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.61%, the 92nd percentile. Fixed in cifs-utils 6.0-1.1.mga3.

References

Show 9 moreShow less
MoveEnter Open