CVE-2014-2892
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows...
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
Exploit likelihood
What each source reports
NVD Score used
7.5
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
- Record
CVE-2014-2892- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
- Record
CVE-2014-2892- Updated
- 2026-11-02
EUVDEUVD-2014-2915 No score
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
- Record
EUVD-2014-2915- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3rq2-3cgx-j4rh No score
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows...
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
- Record
GHSA-3rq2-3cgx-j4rh- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
- Record
CVE-2014-2892- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-2892 No score
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
- Record
DEBIAN-CVE-2014-2892- Updated
- 2026-11-05
OSVMGASA-2014-0190 No score
Updated libmms packages fix CVE-2014-2892
Updated libmms packages fix security vulnerability:
The libmms library before 0.6.4 is vulnerable to a buffer overflow in get_answer() in src/mmsh.c. It may be triggered via an overly long line of a MMSH (MMS over HTTP) server response, effectively overflowing the buffer which has a static size (CVE-2014-2892).
- Record
MGASA-2014-0190- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10109-1 No score
libmms-devel-0.6.4-4.5 on GA media
These are all security issues fixed in the libmms-devel-0.6.4-4.5 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10109-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-2892 No score
Heap-based buffer overflow in the get_answer function in mmsh.c in libmms before 0.6.4 allows remote attackers to execute arbitrary code via a long line in an MMS over HTTP (MMSH) server response.
- Record
UBUNTU-CVE-2014-2892- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libmmsDebian:12 |
before 0.6.2-4 | 0.6.2-4 |
libmmsDebian:13 |
before 0.6.2-4 | 0.6.2-4 |
libmmsDebian:6.0 |
before 0.6-1+squeeze2, plus listed versions 0.6-10.6-1+squeeze1 |
0.6-1+squeeze2 |
libmmsDebian:7 |
before 0.6.2-3+deb7u1, plus listed versions 0.6.2-3 |
0.6.2-3+deb7u1 |
libmmsMageia:3 |
before 0.6.2-3.1.mga3 | 0.6.2-3.1.mga3 |
libmmsMageia:4 |
before 0.6.2-4.1.mga4 | 0.6.2-4.1.mga4 |
libmmsUbuntu:14.04:LTS |
before 0.6.2-3ubuntu2.1, plus listed versions 0.6.2-3ubuntu10.6.2-3ubuntu2 |
0.6.2-3ubuntu2.1 |
libmssopenSUSE:Tumbleweed |
before 0.6.4-4.5 | 0.6.4-4.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-2892 is a high vulnerability (CVSS 7.5) in Libmms Project Libmms, published April 22, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.26%, the 93rd percentile. Fixed in libmms 0.6.2-4.
References
debian.org/security/2014/dsa-2916
securityfocus.com/bid/66933
secunia.com/advisories/57875
sourceforge.net/p/libmms/code/ci/master/tree/ChangeLog
lists.opensuse.org/opensuse-updates/2014-05/msg00001.html
openwall.com/lists/oss-security/2014/04/18/14
Show 11 moreShow less
security.gentoo.org/glsa/201612-29
sourceforge.net/p/libmms/code/ci/03bcfccc22919c72742b7338d02859962861e0e8
exchange.xforce.ibmcloud.com/vulnerabilities/92640
nvd.nist.gov/vuln/detail/CVE-2014-2892
github.com/advisories/GHSA-3rq2-3cgx-j4rh
security-tracker.debian.org/tracker/CVE-2014-2892
advisories.mageia.org/MGASA-2014-0190.html
bugs.mageia.org/show_bug.cgi?id=13235
ubuntu.com/security/CVE-2014-2892
cve.org/CVERecord?id=CVE-2014-2892
suse.com/security/cve/CVE-2014-2892