CVE-2014-2983
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different...
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different anonymous users, which allows remote anonymous users to obtain sensitive interim form input information in opportunistic situations via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
5.0
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different anonymous users, which allows remote anonymous users to obtain sensitive interim form input information in opportunistic situations via unspecified vectors.
- Record
CVE-2014-2983- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different anonymous users, which allows remote anonymous users to obtain sensitive interim form input information in opportunistic situations via unspecified vectors.
- Record
CVE-2014-2983- Updated
- 2026-11-02
EUVDEUVD-2014-3005 No score
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different anonymous users, which allows remote anonymous users to obtain sensitive interim form input information in opportunistic situations via unspecified vectors.
- Record
EUVD-2014-3005- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p4jq-p7qf-pw64 No score
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different...
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different anonymous users, which allows remote anonymous users to obtain sensitive interim form input information in opportunistic situations via unspecified vectors.
- Record
GHSA-p4jq-p7qf-pw64- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVMGASA-2014-0322 No score
Updated drupal packages fix security vulnerabilities
An information disclosure vulnerability was discovered in Drupal before 7.27. When pages are cached for anonymous users, form state may leak between anonymous users. Sensitive or private information recorded for one anonymous user could thus be disclosed to other users interacting with the same form at the same time (CVE-2014-2983).
Multiple security issues in Drupal before 7.29, including a denial of service issue, an access bypass issue in the File module, and multiple cross-site scripting issues (CVE-2014-5019, CVE-2014-5020, CVE-2014-5021, CVE-2014-5022).
Drupal has been updated to version 7.29, fixing this and other bugs.
- Record
MGASA-2014-0322- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-2983 No score
Drupal 6.x before 6.31 and 7.x before 7.27 does not properly isolate the cached data of different anonymous users, which allows remote anonymous users to obtain sensitive interim form input information in opportunistic situations via unspecified vectors.
- Record
UBUNTU-CVE-2014-2983- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
drupal7Debian:7 |
before 7.14-2+deb7u4, plus listed versions 7.14-27.14-2+deb7u17.14-2+deb7u1~bpo60+17.14-2+deb7u27.14-2+deb7u2~bpo60+17.14-2+deb7u37.14-2+deb7u4~bpo60+1 |
7.14-2+deb7u4 |
drupal6Debian:6.0 |
before 6.31-1, plus listed versions 6.18-16.18-1squeeze16.20-16.20-1~bpo50+16.20-1~bpo60+1 Show 9 moreShow less6.20-26.22-16.22-1~bpo60+16.26-16.26-1.16.26-1~bpo60+16.28-16.29-16.30-1 |
6.31-1 |
drupalMageia:3 |
before 7.29-1.mga3 | 7.29-1.mga3 |
drupalMageia:4 |
before 7.29-1.mga4 | 7.29-1.mga4 |
drupal7Ubuntu:Pro:14.04:LTS |
All versions, plus listed versions 7.23-17.24-17.24-27.26-17.26-1ubuntu0.17.26-1ubuntu0.1+esm17.26-1ubuntu0.1+esm27.26-1ubuntu0.1+esm3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-2983 is a medium vulnerability (CVSS 5.0) in Drupal, published April 23, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.60%, the 75th percentile. Fixed in drupal7 7.14-2+deb7u4.
References
debian.org/security/2014/dsa-2913
drupal.org/SA-CORE-2014-002
debian.org/security/2014/dsa-2914
openwall.com/lists/oss-security/2014/04/22/2
nvd.nist.gov/vuln/detail/CVE-2014-2983
github.com/advisories/GHSA-p4jq-p7qf-pw64
Show 12 moreShow less
advisories.mageia.org/MGASA-2014-0322.html
bugs.mageia.org/show_bug.cgi?id=13271
drupal.org/SA-CORE-2014-003
drupal.org/drupal-7.27
drupal.org/drupal-7.27-release-notes
drupal.org/drupal-7.28
drupal.org/drupal-7.28-release-notes
drupal.org/drupal-7.29
drupal.org/drupal-7.29-release-notes
debian.org/security/2014/dsa-2983
ubuntu.com/security/CVE-2014-2983
cve.org/CVERecord?id=CVE-2014-2983