Every CVE Search/ Get API key

CVE-2014-3225

Cobbler Path Traversal vulnerability

4.0 MediumPublic exploitFix available

CVE-2014-3225 is a medium vulnerability (CVSS 4.0) in Cobblerd Cobbler, published May 14, 2014. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 8.88%, the 95th percentile. Fixed in cobbler 2.6.4.

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Exploit likelihood

8.88%Down 5.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Record
CVE-2014-3225
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Record
CVE-2014-3225
Updated
2026-11-02
EUVDEUVD-2022-5762 No score

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Record
EUVD-2022-5762
Updated
2026-11-03
GitHub AdvisoriesGHSA-xc7w-jvhx-p6q9 No score

Cobbler Path Traversal vulnerability

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Record
GHSA-xc7w-jvhx-p6q9
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-xc7w-jvhx-p6q9 No score

Cobbler Path Traversal vulnerability

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Record
GHSA-xc7w-jvhx-p6q9
Weakness
CWE-22
Updated
2026-11-02
OSVopenSUSE-SU-2024:10282-1 No score

cobbler-2.6.6-4.2 on GA media

These are all security issues fixed in the cobbler-2.6.6-4.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10282-1
Updated
2026-11-02
OSVPYSEC-2026-797 No score

Cobbler Path Traversal vulnerability

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Record
PYSEC-2026-797
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3225 No score

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Record
UBUNTU-CVE-2014-3225
Updated
2026-11-02
OSVUSN-6475-1 No score

cobbler vulnerabilities

It was discovered that Cobbler did not properly handle user input, which could result in an absolute path traversal. An attacker could possibly use this issue to read arbitrary files. (CVE-2014-3225)

It was discovered that Cobbler did not properly handle user input, which could result in command injection. An attacker could possibly use this issue to execute arbitrary code with high privileges. (CVE-2017-1000469, CVE-2021-45082)

It was discovered that Cobbler did not properly hide private functions in a class. A remote attacker could possibly use this issue to gain high privileges and upload files to an arbitrary location. (CVE-2018-10931, CVE-2018-1000225, CVE-2018-1000226)

Nicolas Chatelain discovered that Cobbler did not properly handle user input, which could result in log poisoning. A remote attacker could possibly use this issue to bypass authorization, write in an arbitrary file, or execute arbitrary code. (CVE-2021-40323, CVE-2021-40324, CVE-2021-40325)

It was discovered that Cobbler did not properly handle file permissions during package install or update operations. An attacker could possibly use this issue to perform a privilege escalation attack. (CVE-2021-45083)

It was discovered that Cobbler did not properly process credentials for expired accounts. An attacker could possibly use this issue to login to the platform with an expired account or password. (CVE-2022-0860)

Record
USN-6475-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cobbler
PyPI
2.6.0 up to 2.6.4
2.6.4
cobbler
PyPI
2.4.0 up to 2.4.7
2.4.7
cobbler
PyPI
2.4.0 up to 2.4.7, 2.6.0 up to 2.6.4
2.4.72.6.4
cobbler
Ubuntu:Pro:16.04:LTS
before 2.4.1-0ubuntu2+esm1, plus listed versions
2.4.1-0ubuntu2
2.4.1-0ubuntu2+esm1
cobbler
openSUSE:Tumbleweed
before 2.6.6-4.2
2.6.6-4.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBCobbler 2.4.x < 2.6.x - Local File Inclusion2014-05-08

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 24 moreShow less
MoveEnter Open