Every CVE Search/ Get API key

CVE-2014-3495

duplicity 0.6.24 has improper verification of SSL certificates

7.5 HighFix available

duplicity 0.6.24 has improper verification of SSL certificates

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.94%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

duplicity 0.6.24 has improper verification of SSL certificates

Record
CVE-2014-3495
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

duplicity 0.6.24 has improper verification of SSL certificates

Record
CVE-2014-3495
Updated
2026-11-02
EUVDEUVD-2014-3500 No score

duplicity 0.6.24 has improper verification of SSL certificates

Record
EUVD-2014-3500
Updated
2026-11-03
GitHub AdvisoriesGHSA-2xxp-9232-mwj8 7.5

duplicity 0.6.24 has improper verification of SSL certificates

duplicity 0.6.24 has improper verification of SSL certificates

Record
GHSA-2xxp-9232-mwj8
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-295
Updated
2026-11-02
OSV 7.5

duplicity 0.6.24 has improper verification of SSL certificates

Record
CVE-2014-3495
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2014-3495 7.5

duplicity 0.6.24 has improper verification of SSL certificates

Record
DEBIAN-CVE-2014-3495
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
duplicity
Debian:12
before 0.6.21-1
0.6.21-1
duplicity
Debian:13
before 0.6.21-1
0.6.21-1
duplicity
Debian:14
before 0.6.21-1
0.6.21-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3495 is a high vulnerability (CVSS 7.5) in Debian Duplicity, published December 13, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 61st percentile. Fixed in duplicity 0.6.21-1.

References

MoveEnter Open