CVE-2014-3542
Moodle allows remote attackers to read arbitrary files
mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
Exploit likelihood
What each source reports
NVD Score used
4.3
mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
- Record
CVE-2014-3542- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
- Record
CVE-2014-3542- Updated
- 2026-11-02
EUVDEUVD-2022-5831 No score
mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
- Record
EUVD-2022-5831- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xmwv-mqh8-4xgw No score
Moodle allows remote attackers to read arbitrary files
mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
- Record
GHSA-xmwv-mqh8-4xgw- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-xmwv-mqh8-4xgw No score
Moodle allows remote attackers to read arbitrary files
mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
- Record
GHSA-xmwv-mqh8-4xgw- Weakness
- CWE-200
- Updated
- 2026-11-02
OSVMGASA-2014-0308 No score
Updated moodle package fixes security vulnerabilities
In Moodle before 2.6.4, serialised data passed by repositories could potentially contain objects defined by add-ons that could include executable code (CVE-2014-3541).
In Moodle before 2.6.4, it was possible for manipulated XML files passed from LTI servers to be interpreted by Moodle to allow access to server-side files (CVE-2014-3542).
In Moodle before 2.6.4, it was possible for manipulated XML files to be uploaded to the IMSCC course format or the IMSCP resource to allow access to server-side files (CVE-2014-3543).
In Moodle before 2.6.4, filtering of the Skype profile field was not removing potentially harmful code (CVE-2014-3544).
In Moodle before 2.6.4, it was possible to inject code into Calculated questions that would be executed on the server (CVE-2014-3545).
In Moodle before 2.6.4, it was possible to get limited user information, such as user name and courses, by manipulating the URL of profile and notes pages (CVE-2014-3546).
In Moodle before 2.6.4, the details of badges from external sources were not being filtered (CVE-2014-3547).
In Moodle before 2.6.4, content of exception dialogues presented from AJAX calls was not being escaped before being presented to users (CVE-2014-3548).
In Moodle before 2.6.4, fields in rubrics were not being correctly filtered (CVE-2014-3551).
In Moodle before 2.6.4, forum was allowing users who were members of more than one group to post to all groups without the capability to access all groups (CVE-2014-3553).
The moodle package has been updated to version 2.6.4, to fix these issues and other bugs.
- Record
MGASA-2014-0308- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
through 2.3.11 | None known |
moodle/moodlePackagist |
2.4.0 up to 2.4.11 | 2.4.11 |
moodle/moodlePackagist |
2.5.0 up to 2.5.7 | 2.5.7 |
moodle/moodlePackagist |
2.6.0 up to 2.6.4 | 2.6.4 |
moodle/moodlePackagist |
2.7.0 to 2.7.0 | 2.7.1 |
moodle/moodlePackagist |
through 2.3.11, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6v2.3.7v2.3.8v2.3.9 |
None known |
moodle/moodlePackagist |
2.4.0 up to 2.4.11, plus listed versions v2.4.0v2.4.1v2.4.10v2.4.2v2.4.3 Show 6 moreShow lessv2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9 |
2.4.11 |
moodle/moodlePackagist |
2.5.0 up to 2.5.7, plus listed versions v2.5.0v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6 |
2.5.7 |
moodle/moodlePackagist |
2.6.0 up to 2.6.4, plus listed versions v2.6.0v2.6.1v2.6.2v2.6.3 |
2.6.4 |
moodle/moodlePackagist |
2.7.0 up to 2.7.1, plus listed versions v2.7.0 |
2.7.1 |
moodleMageia:3 From an advisory covering 10 CVEs |
before 2.6.4-1.mga3 | 2.6.4-1.mga3 |
moodleMageia:4 From an advisory covering 10 CVEs |
before 2.6.4-1.mga4 | 2.6.4-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-3542 is a medium vulnerability (CVSS 4.3) in Moodle, published July 29, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.35%, the 71st percentile. Fixed in moodle/moodle 2.4.11.
References
openwall.com/lists/oss-security/2014/07/21/1
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-45463
moodle.org/mod/forum/discuss.php?d=264263
nvd.nist.gov/vuln/detail/CVE-2014-3542
github.com/moodle/moodle/commit/78ed99ec7e5e75b283e844adb058140d6ba0ff14
github.com/advisories/GHSA-xmwv-mqh8-4xgw
Show 13 moreShow less
github.com/moodle/moodle
advisories.mageia.org/MGASA-2014-0308.html
bugs.mageia.org/show_bug.cgi?id=13759
moodle.org/mod/forum/discuss.php?d=264262
moodle.org/mod/forum/discuss.php?d=264264
moodle.org/mod/forum/discuss.php?d=264265
moodle.org/mod/forum/discuss.php?d=264266
moodle.org/mod/forum/discuss.php?d=264267
moodle.org/mod/forum/discuss.php?d=264268
moodle.org/mod/forum/discuss.php?d=264269
moodle.org/mod/forum/discuss.php?d=264270
moodle.org/mod/forum/discuss.php?d=264273
docs.moodle.org/dev/Moodle_2.6.4_release_notes