CVE-2014-3548
Moodle multiple cross-site scripting (XSS) vulnerabilities
Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.
Exploit likelihood
What each source reports
NVD Score used
4.3
Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.
- Record
CVE-2014-3548- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.
- Record
CVE-2014-3548- Updated
- 2026-11-02
EUVDEUVD-2022-3701 No score
Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.
- Record
EUVD-2022-3701- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f66h-6mj2-rwj2 No score
Moodle multiple cross-site scripting (XSS) vulnerabilities
Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.
- Record
GHSA-f66h-6mj2-rwj2- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-f66h-6mj2-rwj2 No score
Moodle multiple cross-site scripting (XSS) vulnerabilities
Multiple cross-site scripting (XSS) vulnerabilities in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote attackers to inject arbitrary web script or HTML via vectors that trigger an AJAX exception dialog.
- Record
GHSA-f66h-6mj2-rwj2- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVMGASA-2014-0308 No score
Updated moodle package fixes security vulnerabilities
In Moodle before 2.6.4, serialised data passed by repositories could potentially contain objects defined by add-ons that could include executable code (CVE-2014-3541).
In Moodle before 2.6.4, it was possible for manipulated XML files passed from LTI servers to be interpreted by Moodle to allow access to server-side files (CVE-2014-3542).
In Moodle before 2.6.4, it was possible for manipulated XML files to be uploaded to the IMSCC course format or the IMSCP resource to allow access to server-side files (CVE-2014-3543).
In Moodle before 2.6.4, filtering of the Skype profile field was not removing potentially harmful code (CVE-2014-3544).
In Moodle before 2.6.4, it was possible to inject code into Calculated questions that would be executed on the server (CVE-2014-3545).
In Moodle before 2.6.4, it was possible to get limited user information, such as user name and courses, by manipulating the URL of profile and notes pages (CVE-2014-3546).
In Moodle before 2.6.4, the details of badges from external sources were not being filtered (CVE-2014-3547).
In Moodle before 2.6.4, content of exception dialogues presented from AJAX calls was not being escaped before being presented to users (CVE-2014-3548).
In Moodle before 2.6.4, fields in rubrics were not being correctly filtered (CVE-2014-3551).
In Moodle before 2.6.4, forum was allowing users who were members of more than one group to post to all groups without the capability to access all groups (CVE-2014-3553).
The moodle package has been updated to version 2.6.4, to fix these issues and other bugs.
- Record
MGASA-2014-0308- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 2.4.11 | 2.4.11 |
moodle/moodlePackagist |
2.5.0 up to 2.5.7 | 2.5.7 |
moodle/moodlePackagist |
2.6.0 up to 2.6.4 | 2.6.4 |
moodle/moodlePackagist |
2.7.0 up to 2.7.1 | 2.7.1 |
moodle/moodlePackagist |
before 2.4.11, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 15 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9 |
2.4.11 |
moodle/moodlePackagist |
2.5.0 up to 2.5.7, plus listed versions v2.5.0v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6 |
2.5.7 |
moodle/moodlePackagist |
2.6.0 up to 2.6.4, plus listed versions v2.6.0v2.6.1v2.6.2v2.6.3 |
2.6.4 |
moodle/moodlePackagist |
2.7.0 up to 2.7.1, plus listed versions v2.7.0 |
2.7.1 |
moodleMageia:3 |
before 2.6.4-1.mga3 | 2.6.4-1.mga3 |
moodleMageia:4 |
before 2.6.4-1.mga4 | 2.6.4-1.mga4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-3548 is a medium vulnerability (CVSS 4.3) in Moodle, published July 29, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.83%, the 78th percentile. Fixed in moodle/moodle 2.4.11.
References
openwall.com/lists/oss-security/2014/07/21/1
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-45471
securityfocus.com/bid/68766
moodle.org/mod/forum/discuss.php?d=264270
nvd.nist.gov/vuln/detail/CVE-2014-3548
github.com/moodle/moodle/commit/166e18d7cbb36d58d08a2783edd98284d5a3b98a
Show 18 moreShow less
github.com/moodle/moodle/commit/53ca351f7af8d80a0ff0aba27a1c278fb731d288
github.com/moodle/moodle/commit/6eb787b873f5d3718dc8a74f798ee528d600d8fe
github.com/moodle/moodle/commit/a1ae35173b54ed0c2c3736dfa78cad9899a55d4e
web.archive.org/web/20200228161543/http://www.securityfocus.com/bid/68766
github.com/advisories/GHSA-f66h-6mj2-rwj2
github.com/moodle/moodle
advisories.mageia.org/MGASA-2014-0308.html
bugs.mageia.org/show_bug.cgi?id=13759
moodle.org/mod/forum/discuss.php?d=264262
moodle.org/mod/forum/discuss.php?d=264263
moodle.org/mod/forum/discuss.php?d=264264
moodle.org/mod/forum/discuss.php?d=264265
moodle.org/mod/forum/discuss.php?d=264266
moodle.org/mod/forum/discuss.php?d=264267
moodle.org/mod/forum/discuss.php?d=264268
moodle.org/mod/forum/discuss.php?d=264269
moodle.org/mod/forum/discuss.php?d=264273
docs.moodle.org/dev/Moodle_2.6.4_release_notes