CVE-2014-3564
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2)...
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
Exploit likelihood
What each source reports
NVD Score used
6.8
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Record
CVE-2014-3564- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Record
CVE-2014-3564- Updated
- 2026-11-02
EUVDEUVD-2014-3545 No score
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Record
EUVD-2014-3545- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7jm5-qh8p-8j94 No score
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2)...
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Record
GHSA-7jm5-qh8p-8j94- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Record
CVE-2014-3564- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-3564 No score
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Record
DEBIAN-CVE-2014-3564- Updated
- 2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0340 No score
Updated gpgme packages fix CVE-2014-3564
Updated gpgme packages fix security vulnerability:
A heap-based buffer overflow in gpgme before 1.5.1 could allow a specially crafted certificate to cause crashes or potentially cause arbitrary code execution (CVE-2014-3564).
- Record
MGASA-2014-0340- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10466-1 No score
gpgme-1.8.0-2.1 on GA media
These are all security issues fixed in the gpgme-1.8.0-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10466-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-3564 No score
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Record
UBUNTU-CVE-2014-3564- Updated
- 2026-11-02
OSVUSN-2307-1 No score
gpgme1.0 vulnerability
Tomáš Trnka discovered that GPGME incorrectly handled certain certificate line lengths. An attacker could use this issue to cause applications using GPGME to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-2307-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gpgme1.0Debian:12 |
before 1.5.1-1 | 1.5.1-1 |
gpgme1.0Debian:13 |
before 1.5.1-1 | 1.5.1-1 |
gpgme1.0Debian:14 |
before 1.5.1-1 | 1.5.1-1 |
gpgme1.0Debian:6.0 |
before 1.2.0-1.2+deb6u1, plus listed versions 1.2.0-1.2 |
1.2.0-1.2+deb6u1 |
gpgme1.0Debian:7 |
before 1.2.0-1.4+deb7u1, plus listed versions 1.2.0-1.4 |
1.2.0-1.4+deb7u1 |
gpgmeMageia:3 |
before 1.3.2-2.1.mga3 | 1.3.2-2.1.mga3 |
gpgmeMageia:4 |
before 1.4.3-2.1.mga4 | 1.4.3-2.1.mga4 |
gpgme1.0Ubuntu:14.04:LTS |
before 1.4.3-0.1ubuntu5.1, plus listed versions 1.4.2-0.1ubuntu31.4.3-0.1ubuntu21.4.3-0.1ubuntu31.4.3-0.1ubuntu5 |
1.4.3-0.1ubuntu5.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-3564 is a medium vulnerability (CVSS 6.8) in Gnu Gpgme, published August 1, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.29%, the 91st percentile. Fixed in gpgme1.0 1.5.1-1.
References
osvdb.org/109699
securityfocus.com/bid/68990
debian.org/security/2014/dsa-3005
git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git%3Ba=commit%3Bh=2cbd76f7911fc215845e89b50d6af5ff4a83dd77
bugzilla.redhat.com/show_bug.cgi?id=1113267
seclists.org/oss-sec/2014/q3/266
Show 11 moreShow less
oracle.com/technetwork/topics/security/bulletinoct2015-2511968.html
nvd.nist.gov/vuln/detail/CVE-2014-3564
git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commit;h=2cbd76f7911fc215845e89b50d6af5ff4a83dd77
github.com/advisories/GHSA-7jm5-qh8p-8j94
security-tracker.debian.org/tracker/CVE-2014-3564
advisories.mageia.org/MGASA-2014-0340.html
bugs.mageia.org/show_bug.cgi?id=13827
ubuntu.com/security/CVE-2014-3564
ubuntu.com/security/notices/USN-2307-1
cve.org/CVERecord?id=CVE-2014-3564
suse.com/security/cve/CVE-2014-3564