Every CVE Search/ Get API key

CVE-2014-3583

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP...

5.0 MediumFix available

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Exploit likelihood

10.8%Up 5.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Record
CVE-2014-3583
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Record
CVE-2014-3583
Updated
2026-11-02
EUVDEUVD-2014-3559 No score

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Record
EUVD-2014-3559
Updated
2026-11-03
GitHub AdvisoriesGHSA-jh98-gwvf-4vf3 No score

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP...

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Record
GHSA-jh98-gwvf-4vf3
Weakness
CWE-119
Updated
2026-11-02
OSVBELL-CVE-2014-3583 5.0

CVE-2014-3583 does not affect BellSoft software

Record
BELL-CVE-2014-3583
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
OSV No score

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Record
CVE-2014-3583
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2014-3583 No score

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Record
DEBIAN-CVE-2014-3583
Updated
2026-11-02
OSVopenSUSE-SU-2024:10268-1 No score

apache2-2.4.23-4.1 on GA media

These are all security issues fixed in the apache2-2.4.23-4.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10268-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3583 No score

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

Record
UBUNTU-CVE-2014-3583
Updated
2026-11-02
OSVUSN-2523-1 No score

apache2 vulnerabilities

Martin Holst Swende discovered that the mod_headers module allowed HTTP trailers to replace HTTP headers during request processing. A remote attacker could possibly use this issue to bypass RequestHeaders directives. (CVE-2013-5704)

Mark Montague discovered that the mod_cache module incorrectly handled empty HTTP Content-Type headers. A remote attacker could use this issue to cause the server to stop responding, leading to a denial of service. This issue only affected Ubuntu 14.04 LTS and Ubuntu 14.10. (CVE-2014-3581)

Teguh P. Alko discovered that the mod_proxy_fcgi module incorrectly handled long response headers. A remote attacker could use this issue to cause the server to stop responding, leading to a denial of service. This issue only affected Ubuntu 14.10. (CVE-2014-3583)

It was discovered that the mod_lua module incorrectly handled different arguments within different contexts. A remote attacker could possibly use this issue to bypass intended access restrictions. This issue only affected Ubuntu 14.10. (CVE-2014-8109)

Guido Vranken discovered that the mod_lua module incorrectly handled a specially crafted websocket PING in certain circumstances. A remote attacker could possibly use this issue to cause the server to stop responding, leading to a denial of service. This issue only affected Ubuntu 14.10. (CVE-2015-0228)

Record
USN-2523-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache2
Debian:12
before 2.4.10-8
2.4.10-8
apache2
Debian:13
before 2.4.10-8
2.4.10-8
apache2
Debian:14
before 2.4.10-8
2.4.10-8
mod_proxy_fcgi
Red Hat:rhel_common:6::el6
before 0:2.4.10-5.20150415gitd45a11f.el6cp
0:2.4.10-5.20150415gitd45a11f.el6cp
mod_proxy_fcgi-debuginfo
Red Hat:rhel_common:6::el6
before 0:2.4.10-5.20150415gitd45a11f.el6cp
0:2.4.10-5.20150415gitd45a11f.el6cp
apache2
Ubuntu:14.04:LTS
before 2.4.7-1ubuntu4.4, plus listed versions
2.4.6-2ubuntu22.4.6-2ubuntu32.4.6-2ubuntu42.4.7-1ubuntu12.4.7-1ubuntu22.4.7-1ubuntu32.4.7-1ubuntu42.4.7-1ubuntu4.1
2.4.7-1ubuntu4.4
apache2
openSUSE:Tumbleweed
before 2.4.23-4.1
2.4.23-4.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3583 is a medium vulnerability (CVSS 5.0) in Apache Http Server, published December 15, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.8%, the 95th percentile. Fixed in apache2 2.4.10-8.

References

Show 96 moreShow less
MoveEnter Open