Every CVE Search/ Get API key

CVE-2014-3628

Improper Neutralization of Input During Web Page Generation in Apache Solr

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

Exploit likelihood

4.70%Up 3.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

Record
CVE-2014-3628
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

Record
CVE-2014-3628
Updated
2026-11-02
EUVDEUVD-2022-5574 No score

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

Record
EUVD-2022-5574
Updated
2026-11-03
GitHub AdvisoriesGHSA-wgw2-gw4v-9w4j No score

Improper Neutralization of Input During Web Page Generation in Apache Solr

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

Record
GHSA-wgw2-gw4v-9w4j
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-wgw2-gw4v-9w4j No score

Improper Neutralization of Input During Web Page Generation in Apache Solr

Cross-site scripting (XSS) vulnerability in the Admin UI Plugin / Stats page in Apache Solr 4.x before 4.10.3 allows remote attackers to inject arbitrary web script or HTML via the fieldvaluecache object.

Record
GHSA-wgw2-gw4v-9w4j
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.solr:solr
Maven
4.0.0 up to 4.10.3
4.10.3
org.apache.solr:solr
Maven
4.0.0 up to 4.10.3, plus listed versions
4.1.04.10.04.10.14.10.24.2.0
Show 15 moreShow less
4.2.14.3.04.3.14.4.04.5.04.5.14.6.04.6.14.7.04.7.14.7.24.8.04.8.14.9.04.9.1
4.10.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3628 is a medium vulnerability (CVSS 4.3) in Apache Solr, published January 6, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.70%, the 91st percentile. Fixed in org.apache.solr:solr 4.10.3.

References

MoveEnter Open