Every CVE Search/ Get API key

CVE-2014-3638

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x...

2.1 LowFix available

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Exploit likelihood

0.39%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Record
CVE-2014-3638
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Record
CVE-2014-3638
Updated
2026-11-02
EUVDEUVD-2014-3596 No score

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Record
EUVD-2014-3596
Updated
2026-11-03
GitHub AdvisoriesGHSA-c2g7-vg4j-w539 No score

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x...

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Record
GHSA-c2g7-vg4j-w539
Updated
2026-11-02
OSV No score

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Record
CVE-2014-3638
Updated
2026-11-02
OSVDEBIAN-CVE-2014-3638 No score

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Record
DEBIAN-CVE-2014-3638
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0395 No score

Updated dbus packages fix multiple security vulnerabilities

Updated dbus packages fixes the following security issues:

Alban Crequy and Simon McVittie discovered several vulnerabilities in the D-Bus message daemon:

On 64-bit platforms, file descriptor passing could be abused by local users to cause heap corruption in dbus-daemon, leading to a crash, or potentially to arbitrary code execution (CVE-2014-3635).

A denial-of-service vulnerability in dbus-daemon allowed local attackers to prevent new connections to dbus-daemon, or disconnect existing clients, by exhausting descriptor limits (CVE-2014-3636).

Malicious local users could create D-Bus connections to dbus-daemon which could not be terminated by killing the participating processes, resulting in a denial-of-service vulnerability (CVE-2014-3637).

dbus-daemon suffered from a denial-of-service vulnerability in the code which tracks which messages expect a reply, allowing local attackers to reduce the performance of dbus-daemon (CVE-2014-3638).

dbus-daemon did not properly reject malicious connections from local users, resulting in a denial-of-service vulnerability (CVE-2014-3639).

Record
MGASA-2014-0395
Updated
2026-11-02
OSVopenSUSE-SU-2024:10517-1 No score

dbus-1-1.10.12-2.1 on GA media

These are all security issues fixed in the dbus-1-1.10.12-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10517-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3638 No score

The bus_connections_check_reply function in config-parser.c in D-Bus before 1.6.24 and 1.8.x before 1.8.8 allows local users to cause a denial of service (CPU consumption) via a large number of method calls.

Record
UBUNTU-CVE-2014-3638
Updated
2026-11-02
OSVUSN-2352-1 No score

dbus vulnerabilities

Simon McVittie discovered that DBus incorrectly handled the file descriptors message limit. A local attacker could use this issue to cause DBus to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2014-3635)

Alban Crequy discovered that DBus incorrectly handled a large number of file descriptor messages. A local attacker could use this issue to cause DBus to stop responding, resulting in a denial of service. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2014-3636)

Alban Crequy discovered that DBus incorrectly handled certain file descriptor messages. A local attacker could use this issue to cause DBus to maintain persistent connections, possibly resulting in a denial of service. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2014-3637)

Alban Crequy discovered that DBus incorrectly handled a large number of parallel connections and parallel message calls. A local attacker could use this issue to cause DBus to consume resources, possibly resulting in a denial of service. (CVE-2014-3638)

Alban Crequy discovered that DBus incorrectly handled incomplete connections. A local attacker could use this issue to cause DBus to fail legitimate connection attempts, resulting in a denial of service. (CVE-2014-3639)

Record
USN-2352-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dbus
Debian:12
before 1.8.8-1
1.8.8-1
dbus
Debian:13
before 1.8.8-1
1.8.8-1
dbus
Debian:14
before 1.8.8-1
1.8.8-1
dbus
Debian:6.0
before 1.2.24-4+squeeze3, plus listed versions
1.2.24-41.2.24-4+squeeze11.2.24-4+squeeze2
1.2.24-4+squeeze3
dbus
Debian:7
before 1.6.8-1+deb7u4, plus listed versions
1.6.8-11.6.8-1+deb7u11.6.8-1+deb7u21.6.8-1+deb7u3
1.6.8-1+deb7u4
dbus
Mageia:3
before 1.6.8-4.5.mga3
1.6.8-4.5.mga3
dbus
Mageia:4
before 1.6.18-1.4.mga4
1.6.18-1.4.mga4
dbus
Ubuntu:14.04:LTS
before 1.6.18-0ubuntu4.2, plus listed versions
1.6.12-0ubuntu101.6.18-0ubuntu11.6.18-0ubuntu21.6.18-0ubuntu31.6.18-0ubuntu41.6.18-0ubuntu4.1
1.6.18-0ubuntu4.2
dbus-1
openSUSE:Tumbleweed
before 1.10.12-2.1
1.10.12-2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3638 is a low vulnerability (CVSS 2.1) in D-bus Project D-bus, published September 16, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 33rd percentile. Fixed in dbus 1.8.8-1.

References

Show 30 moreShow less
MoveEnter Open