Every CVE Search/ Get API key

CVE-2014-3665

Jenkins improperly ensures trust separation

6.8 MediumFix available

Jenkins before 1.587 and LTS before 1.580.1 do not properly ensure trust separation between a master and slaves, which might allow remote attackers to execute arbitrary code on the master by leveraging access to the slave.

Exploit likelihood

2.50%Down 4.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Jenkins before 1.587 and LTS before 1.580.1 do not properly ensure trust separation between a master and slaves, which might allow remote attackers to execute arbitrary code on the master by leveraging access to the slave.

Record
CVE-2014-3665
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Jenkins before 1.587 and LTS before 1.580.1 do not properly ensure trust separation between a master and slaves, which might allow remote attackers to execute arbitrary code on the master by leveraging access to the slave.

Record
CVE-2014-3665
Updated
2026-11-02
EUVDEUVD-2022-2725 No score

Jenkins before 1.587 and LTS before 1.580.1 do not properly ensure trust separation between a master and slaves, which might allow remote attackers to execute arbitrary code on the master by leveraging access to the slave.

Record
EUVD-2022-2725
Updated
2026-11-03
GitHub AdvisoriesGHSA-66cr-6whx-732p No score

Jenkins improperly ensures trust separation

Jenkins prior to 1.587 and LTS before 1.580.1 do not properly ensure trust separation between a master and slaves, which might allow remote attackers to execute arbitrary code on the master by leveraging access to the slave.

Record
GHSA-66cr-6whx-732p
Updated
2026-11-02
OSVGHSA-66cr-6whx-732p No score

Jenkins improperly ensures trust separation

Jenkins prior to 1.587 and LTS before 1.580.1 do not properly ensure trust separation between a master and slaves, which might allow remote attackers to execute arbitrary code on the master by leveraging access to the slave.

Record
GHSA-66cr-6whx-732p
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.jenkins-ci.main:jenkins-core
Maven
before 1.587
1.587
org.jenkins-ci.main:jenkins-core
Maven
before 1.587, plus listed versions
1.3961.3971.3981.3991.400
Show 45 moreShow less
1.4011.4031.4041.4051.4061.4071.4081.4091.409.11.409.21.409.31.4101.4111.4121.4131.4141.4151.4161.4171.4181.4191.4201.4211.4221.4231.4241.424.11.424.21.424.31.424.41.424.51.424.61.4251.4261.4271.4281.4291.4301.4311.4321.4331.4341.4351.4361.437
1.587
jenkins
Red Hat:openshift:2.0::el6
From an advisory covering 22 CVEs
before 0:1.565.3-1.el6op
0:1.565.3-1.el6op
jenkins-plugin-openshift
Red Hat:openshift:2.0::el6
From an advisory covering 22 CVEs
before 0:0.6.40.1-0.el6op
0:0.6.40.1-0.el6op
openshift-origin-cartridge-jenkins
Red Hat:openshift:2.0::el6
From an advisory covering 22 CVEs
before 0:1.20.3.5-1.el6op
0:1.20.3.5-1.el6op

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3665 is a medium vulnerability (CVSS 6.8) in Jenkins, published November 25, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.50%, the 84th percentile. Fixed in org.jenkins-ci.main:jenkins-core 1.587.

References

Show 89 moreShow less
This page doesn't list everything

Left out here: 185 versions. The JSON record has them.

MoveEnter Open