CVE-2014-3743
Multiple Content Injection Vulnerabilities in marked
CVE-2014-3743 is a medium vulnerability (CVSS 6.1) in Marked Project Marked, published January 6, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.71%, the 77th percentile. Fixed in marked 0.3.1.
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
- Record
CVE-2014-3743- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
- Record
CVE-2014-3743- Updated
- 2026-11-02
EUVDEUVD-2020-0605 No score
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
- Record
EUVD-2020-0605- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9cw2-jqp5-7x39
6.1
Multiple Content Injection Vulnerabilities in marked
Versions 0.3.0 and earlier of marked are affected by two cross-site scripting vulnerabilities, even when sanitize: true is set.
The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs.
Recommendation
Upgrade to version 0.3.1 or later.
- Record
GHSA-9cw2-jqp5-7x39- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
- Record
CVE-2014-3743- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-3743
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
- Record
DEBIAN-CVE-2014-3743- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-9cw2-jqp5-7x39
6.1
Multiple Content Injection Vulnerabilities in marked
Versions 0.3.0 and earlier of marked are affected by two cross-site scripting vulnerabilities, even when sanitize: true is set.
The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs.
Recommendation
Upgrade to version 0.3.1 or later.
- Record
GHSA-9cw2-jqp5-7x39- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2014-3743
6.1
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's. sanitize: true Even if this option is set, marked is vulnerable to content injection in multiple locations if untrusted user input is allowed to be provided into marked and that output is passed to the browser. Injection is possible in two locations * gfm codeblocks (language) * javascript url's
- Record
UBUNTU-CVE-2014-3743- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVCLSA-2026-1773188128 No score
TuxCare security update for marked (8 CVEs)
TuxCare rebuilt marked to address 8 CVEs. Fixed in 0.2.10-tuxcare.1.
- Record
CLSA-2026-1773188128- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
markednpm |
through 0.3.0 | 0.3.1 |
markedTuxCare:npm |
0.2.10-tuxcare.0 up to 0.2.10-tuxcare.1, plus listed versions 0.2.10 |
0.2.10-tuxcare.1 |
node-markedDebian:12 |
before 0.3.1+dfsg-1 | 0.3.1+dfsg-1 |
node-markedDebian:13 |
before 0.3.1+dfsg-1 | 0.3.1+dfsg-1 |
node-markedDebian:14 |
before 0.3.1+dfsg-1 | 0.3.1+dfsg-1 |
markednpm |
before 0.3.1 | 0.3.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | affected | |
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
nodesecurity.io/advisories/marked_multiple_content_injection_vulnerabilities
openwall.com/lists/oss-security/2014/05/13/1
openwall.com/lists/oss-security/2014/05/15/2
bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-3743
nvd.nist.gov/vuln/detail/CVE-2014-1850
npmjs.com/advisories/22
Show 6 moreShow less
github.com/advisories/GHSA-9cw2-jqp5-7x39
security-tracker.debian.org/tracker/CVE-2014-3743
ubuntu.com/security/CVE-2014-3743
openwall.com/lists/oss-security/2014/05/14
web.archive.org/web/20150502141648/https://nodesecurity.io/advisories/marked_multiple_content_injection_vulnerabilities
cve.org/CVERecord?id=CVE-2014-3743