Every CVE Search/ Get API key

CVE-2014-3775

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows...

7.5 HighFix available

CVE-2014-3775 is a high vulnerability (CVSS 7.5) in Libgadu, published May 20, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.78%, the 89th percentile. Fixed in libgadu 1:1.12.0~rc3-1.

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Exploit likelihood

3.78%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Record
CVE-2014-3775
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Record
CVE-2014-3775
Updated
2026-11-02
EUVDEUVD-2014-3714 No score

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Record
EUVD-2014-3714
Updated
2026-11-03
GitHub AdvisoriesGHSA-gwr9-jc3r-3ff3 No score

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows...

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Record
GHSA-gwr9-jc3r-3ff3
Weakness
CWE-20
Updated
2026-11-02
OSV No score

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Record
CVE-2014-3775
Updated
2026-11-02
OSVDEBIAN-CVE-2014-3775 No score

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Record
DEBIAN-CVE-2014-3775
Updated
2026-11-02
Show 5 moreShow less
OSVMGASA-2014-0246 No score

Updated libgadu package fixes CVE-2014-3775

Updated libgadu packages fix security vulnerability:

It was discovered that libgadu incorrectly handled certain messages from file relay servers. A malicious remote server or a man in the middle could use this issue to cause applications using libgadu to crash, resulting in a denial of service, or possibly execute arbitrary code (CVE-2014-3775).

Record
MGASA-2014-0246
Updated
2026-11-02
OSVMGASA-2014-0295 No score

Updated pidgin packages fix CVE-2014-3775

Updated pidgin packages fix security vulnerability:

It was discovered that libgadu incorrectly handled certain messages from file relay servers. A malicious remote server or a man in the middle could use this issue to cause applications using libgadu to crash, resulting in a denial of service, or possibly execute arbitrary code (CVE-2014-3775).

The pidgin package was built with a bundled copy of the libgadu library which contained the vulnerable code. It has now been built against the external libgadu library, which had been fixed in a previous update.

This update also fixes an issue with the Yahoo! protocol that was caused by a bad interaction with the GnuTLS library.

Record
MGASA-2014-0295
Updated
2026-11-02
OSVopenSUSE-SU-2024:10343-1 No score

libgadu-devel-1.12.1-1.10 on GA media

These are all security issues fixed in the libgadu-devel-1.12.1-1.10 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10343-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3775 No score

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

Record
UBUNTU-CVE-2014-3775
Updated
2026-11-02
OSVUSN-2216-1 No score

pidgin vulnerability

It was discovered that Pidgin incorrectly handled certain messages from Gadu-Gadu file relay servers. A malicious remote server or a machine-in-the-middle could use this issue to cause Pidgin to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-2216-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libgadu
Debian:12
before 1:1.12.0~rc3-1
1:1.12.0~rc3-1
libgadu
Debian:13
before 1:1.12.0~rc3-1
1:1.12.0~rc3-1
libgadu
Debian:14
before 1:1.12.0~rc3-1
1:1.12.0~rc3-1
libgadu
Debian:7
before 1:1.11.2-1+deb7u2, plus listed versions
1:1.11.2-11:1.11.2-1+deb7u1
1:1.11.2-1+deb7u2
libgadu
Mageia:3
before 1.11.4-1.mga3
1.11.4-1.mga3
libgadu
Mageia:4
before 1.11.4-1.mga4
1.11.4-1.mga4
pidgin
Mageia:3
before 2.10.9-1.1.mga3
2.10.9-1.1.mga3
pidgin
Mageia:4
before 2.10.9-1.1.mga4
2.10.9-1.1.mga4
pidgin
Ubuntu:14.04:LTS
before 1:2.10.9-0ubuntu3.1, plus listed versions
1:2.10.7-0ubuntu4.11:2.10.7-0ubuntu4.21:2.10.9-0ubuntu11:2.10.9-0ubuntu21:2.10.9-0ubuntu3
1:2.10.9-0ubuntu3.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 23 moreShow less
MoveEnter Open