CVE-2014-4326
Elasticsearch Logstash allows remote attackers to execute arbitrary commands
Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.
Exploit likelihood
What each source reports
NVD Score used
7.5
Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.
- Record
CVE-2014-4326- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.
- Record
CVE-2014-4326- Updated
- 2026-11-02
EUVDEUVD-2014-4254 No score
Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.
- Record
EUVD-2014-4254- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8qhq-rq4j-8prj
8.1
Elasticsearch Logstash allows remote attackers to execute arbitrary commands
Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.
- Record
GHSA-8qhq-rq4j-8prj- CVSS 4.0
- 8.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-78
- Updated
- 2026-11-02
OSVGHSA-8qhq-rq4j-8prj
8.1
Elasticsearch Logstash allows remote attackers to execute arbitrary commands
Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.
- Record
GHSA-8qhq-rq4j-8prj- CVSS 4.0
- 8.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-78
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
logstashRubyGems |
1.0.14 up to 1.4.2 | 1.4.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-4326 is a high vulnerability (CVSS 7.5) in Elastic Logstash, published July 22, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.30%, the 88th percentile. Fixed in logstash 1.4.2.
References
elasticsearch.org/blog/logstash-1-4-2
securityfocus.com/archive/1/532841/100/0/threaded
elastic.co/community/security
nvd.nist.gov/vuln/detail/CVE-2014-4326
web.archive.org/web/20140804031140/http://www.elasticsearch.org/blog/logstash-1-4-2
web.archive.org/web/20201207013408/http://www.securityfocus.com/archive/1/532841/100/0/threaded
github.com/advisories/GHSA-8qhq-rq4j-8prj
github.com/elastic/logstash