Every CVE Search/ Get API key

CVE-2014-4338

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access...

4.0 MediumFix available

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Exploit likelihood

3.01%Up 1.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Record
CVE-2014-4338
CVSS 2.0
4.0 MediumAV:N/AC:H/Au:N/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Record
CVE-2014-4338
Updated
2026-11-02
EUVDEUVD-2014-4265 No score

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Record
EUVD-2014-4265
Updated
2026-11-03
GitHub AdvisoriesGHSA-5hcw-w537-f2mc No score

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access...

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Record
GHSA-5hcw-w537-f2mc
Updated
2026-11-02
OSV No score

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Record
CVE-2014-4338
Updated
2026-11-02
OSVDEBIAN-CVE-2014-4338 No score

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Record
DEBIAN-CVE-2014-4338
Updated
2026-11-02
OSVMGASA-2014-0267 No score

Updated cups-filter packages fix security vulnerabilities

In cups-filters before 1.0.53, out-of-bounds accesses in the process_browse_data function when reading the packet variable could leading to a crash, thus resulting in a denial of service (CVE-2014-4337).

In cups-filters before 1.0.53, if there was only a single BrowseAllow line in cups-browsed.conf and its host specification was invalid, this was interpreted as if no BrowseAllow line had been specified, which resulted in it accepting browse packets from all hosts (CVE-2014-4338).

The CVE-2014-2707 issue with malicious broadcast packets, which had been fixed in Mageia Bug 13216 (MGASA-2014-0181), had not been completely fixed by that update. A more complete fix was implemented in cups-filters 1.0.53 (CVE-2014-4336).

Note that only systems that have enabled the affected feature by using the CreateIPPPrinterQueues configuration directive in /etc/cups/cups-browsed.conf were affected by the CVE-2014-2707 / CVE-2014-4336 issue.

Record
MGASA-2014-0267
Updated
2026-11-02
OSVopenSUSE-SU-2024:10313-1 No score

cups-filters-1.8.2-1.11 on GA media

These are all security issues fixed in the cups-filters-1.8.2-1.11 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10313-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-4338 No score

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

Record
UBUNTU-CVE-2014-4338
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cups-filters
Debian:12
before 1.0.53-1
1.0.53-1
cups-filters
Debian:13
before 1.0.53-1
1.0.53-1
cups-filters
Debian:14
before 1.0.53-1
1.0.53-1
cups-filters
Mageia:4
From an advisory covering 3 CVEs
before 1.0.53-1.mga4
1.0.53-1.mga4
cups-filters
Red Hat:enterprise_linux:7::client
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-debuginfo
Red Hat:enterprise_linux:7::client
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-libs
Red Hat:enterprise_linux:7::client
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-devel
Red Hat:enterprise_linux:7::client
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters
Red Hat:enterprise_linux:7::computenode
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-debuginfo
Red Hat:enterprise_linux:7::computenode
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
Show 12 moreShow less
Affected packages
PackageAffectedFixed
cups-filters-libs
Red Hat:enterprise_linux:7::computenode
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-devel
Red Hat:enterprise_linux:7::computenode
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters
Red Hat:enterprise_linux:7::server
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-debuginfo
Red Hat:enterprise_linux:7::server
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-libs
Red Hat:enterprise_linux:7::server
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-devel
Red Hat:enterprise_linux:7::server
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters
Red Hat:enterprise_linux:7::workstation
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-debuginfo
Red Hat:enterprise_linux:7::workstation
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-libs
Red Hat:enterprise_linux:7::workstation
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters-devel
Red Hat:enterprise_linux:7::workstation
From an advisory covering 2 CVEs
before 0:1.0.35-15.el7_0.1
0:1.0.35-15.el7_0.1
cups-filters
Ubuntu:14.04:LTS
before 1.0.52-0ubuntu1.1, plus listed versions
1.0.40-0ubuntu11.0.40-0ubuntu21.0.41-0ubuntu11.0.41-21.0.42-1
Show 13 moreShow less
1.0.42-21.0.43-11.0.44-11.0.44-21.0.45-11.0.46-0ubuntu11.0.47-0ubuntu11.0.48-0ubuntu11.0.48-0ubuntu21.0.49-0ubuntu11.0.50-0ubuntu11.0.51-0ubuntu11.0.52-0ubuntu1
1.0.52-0ubuntu1.1
cups-filters
openSUSE:Tumbleweed
From an advisory covering 13 CVEs
before 1.8.2-1.11
1.8.2-1.11

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-4338 is a medium vulnerability (CVSS 4.0) in Linuxfoundation Cups-filters, published June 19, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.01%, the 87th percentile. Fixed in cups-filters 1.0.53-1.

References

Show 33 moreShow less
MoveEnter Open