CVE-2014-4510
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote...
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
- Record
CVE-2014-4510- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
- Record
CVE-2014-4510- Updated
- 2026-11-02
EUVDEUVD-2014-4437 No score
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
- Record
EUVD-2014-4437- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-88px-gmr4-m3f2 No score
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote...
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
- Record
GHSA-88px-gmr4-m3f2- Weakness
- CWE-352
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
- Record
CVE-2014-4510- Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-4510 No score
Cross-site scripting (XSS) vulnerability in job.cc in apt-cacher-ng 0.7.26 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
- Record
DEBIAN-CVE-2014-4510- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apt-cacher-ngDebian:12 |
before 0.7.26-2 | 0.7.26-2 |
apt-cacher-ngDebian:13 |
before 0.7.26-2 | 0.7.26-2 |
apt-cacher-ngDebian:14 |
before 0.7.26-2 | 0.7.26-2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-4510 is a medium vulnerability (CVSS 4.3) in Debian Apt-cacher, published October 6, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in apt-cacher-ng 0.7.26-2.
References
seclists.org/oss-sec/2014/q2/603
securityfocus.com/bid/68136
anonscm.debian.org/cgit/apt-cacher-ng/apt-cacher-ng.git/diff?id=6f08e6a3995d1bed4e837889a3945b6dc650f6ad
seclists.org/oss-sec/2014/q2/602
bugzilla.redhat.com/show_bug.cgi?id=1111807
sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-misc/apt-cacher-ng/files/apt-cacher-ng-0.7.26-CVE-2014-4510.patch?view=markup
nvd.nist.gov/vuln/detail/CVE-2014-4510
github.com/advisories/GHSA-88px-gmr4-m3f2
security-tracker.debian.org/tracker/CVE-2014-4510